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Solving SQL6028N error with catalog command on Windows

Troubleshooting


Problem

Running the db2 catalog command in order to catalog the Tivoli Storage Manager server database fails with error SQL6028N.

Cause

Incorrect database directory path was used with the db2 catalog command.

Environment

Tivoli Storage Manager Server on Windows

Diagnosing The Problem

The catalog command fails to catalog the Tivoli Storage Manager database (TSMDB1). For example :

set DB2INSTANCE=Server1
db2 catalog db tsmdb1 on D:\TSMDB


SQL6028N Catalog database failed because database "TSMDB1" was not found in the local database directory.

Resolving The Problem

Follow the below steps to correct the issue.

  1. Find the correct instance directory. For example:
    more
    ...
    <Instance>
    <InstanceName>server1</InstanceName>
    <InstanceUser>server1</InstanceUser>
    <DefaultDatabasePath>d:\tsm\server1</DefaultDatabasePath>
    <Database>
    <DatabaseName>TSMDB1</DatabaseName>
    <DatabasePath>D:\TSMDB\server1</DatabasePath>
    </Database>
    ...
    </Instance>

    In above example, the database path is "D:\TSMDB\Server1" while the above db2 catalog command was used with "D:\TSMDB" as database path.
  2. Re-run the failed command using the correct database path. For example :
    set DB2INSTANCE=Server1
    db2 catalog db tsmdb1 on D:\TSMDB\Server1

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Supported Versions","Edition":"All Editions","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21461884