Troubleshooting
Problem
SMTP Server jobs fail to start and issue a TCP2074 in joblog
Symptom
TCP2074
Cause
This issue is caused by a problem or a change in TCP configuration
Resolving The Problem
Review this document for a possible solution to this issue before reviewing the rest of this technical document: https://www.ibm.com/support/pages/node/642573
The SMTP jobs should stay active now. If they do not contact IBM Support for further assistance.
If that document does not help, examine your TCP2074 in more depth.
If in the recovery it states:
- The fully qualified host name for this system is:
*ERROR NO VALID INTERFACES IN BND LIST
We recommend the following steps:
- Execute both:
WRKMBRPDM FILE(QUSRSYS/QATMIFCLST) then WRKMBRPDM FILE(QUSRSYS/QATMIP6IFC)
Look at the members CLNTBNDIP and SVRBNDIP.
DO NOT EDIT THESE FILES.
If you see only an IP that is not active on this system, we have discovered the issue. - Next, execute the following steps to remove the old IP address you are binding to:
RMVSMTPLE TYPE(*SVRBIND) INTNETADR(XXX.XXX.XXX.XXX) then RMVSMTPLE TYPE(*CLTBIND) INTNETADR(XXX.XXX.XXX.XXX)
ADDSMTPLE TYPE(*SVRBIND) INTNETADR(XXX.XXX.XXX.XXX) then ADDSMTPLE TYPE(*CLTBIND) INTNETADR(XXX.XXX.XXX.XXX)
- Restart the SMTP server
The SMTP jobs should stay active now. If they do not contact IBM Support for further assistance.
Related Information
[{"Type":"MASTER","Line of Business":{"code":"LOB57","label":"Power"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SWG60","label":"IBM i"},"Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0"}]
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Document Information
Modified date:
27 February 2020
UID
nas8N1019825