IBM Support

SMTP does not deliver the mail.

Troubleshooting


Problem

SMTP stops delivering mail if the current email can't be delivered due to a temporary error condition causing the email to be retried.

Symptom

SMTP stops processing mail

Cause

When SMTP sends out an email, it resolves it to an IP address. If an email queued to that IP address is having problems getting delivered, other mail resolved to this IP address will not be delivered until SMTP has completed that email. This occurs when the type of error is considered a temporary error condition. For example, the remote SMTP server replies with a 4xx reply code for that email or a timeout occurs on the connection while sending that email.

Resolving The Problem

If you are going to investigate this problem further, rename the ADDRBLOK and NOTE datasets associated with this email so they can be sent to the Level 2 team. Otherwise, delete the ADDRBLOK and NOTE datasets associated with this email.

The combination of the following two parameters could have automatically removed the problem mail from the send queue.

TEMPERRORRETRIES - number of times SMTP attempts to deliver mail
RETRYINT - number of minutes SMTP should wait between attempts to deliver the mail (default 20). Refer to z/OS Comm Svr: IP Configuration Reference in the section titled Summary of SMTP Configuration Statements for more information on these parameters.

[{"Product":{"code":"SSSN3L","label":"z\/OS Communications Server"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"--","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"1.8;1.9;1.10;1.11;1.12;1.13;2.1;2.2","Edition":"Enterprise","Line of Business":{"code":"LOB35","label":"Mainframe SW"}}]

Document Information

Modified date:
15 June 2018

UID

swg21384893