IBM Support

Slow performance launching Controller client, caused by remote (slow) Domain Controller

Troubleshooting


Problem

User launches Controller client. User progresses through the steps (for example choosing database, logging onto Controller). It takes a long time for these steps to complete (before the Controller client has finally launched).

Symptom

In one real-life customer example, users took approximately 5-10 minutes to logon.

The problem may only affect some users.

  • In one real-life customer example, the problem only affected Asian users.

Cause

There are many possible causes for slow client logon times.

  • TIP: For more examples, see separate IBM Technote #1367308.

This Technote specifically relates to the scenario where the cause is that the customer's application servers are using a

Example:
In one real-life customer example, the Controller application server was hosted in Denmark. The Asian users were authenticating to a namespace which used a domain controller (DC) also hosted in Denmark. However, this DC failed, which meant that the system failed over to use a different DC which was hosted in Shanghai (China).
  • The slow network (high latency) between Denmark and China caused the slow authentication/logons for Asian users.

Resolving The Problem

Ensure that the Cognos CAM namespace is configured to use a domain controller that is close to the Controller application server (fast network between both machines).

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg22012694