Troubleshooting
Problem
User clicks F9 to run/refresh an Excel-link report. This takes a long time (or may actually appear to never finish).
Symptom
Main symptom
Slow performance when running Excel link reports.
Secondary symptom
In some circumstances, it has been seen that (sometimes - intermittently) Controller goes into a 'loop'.
- Specifically, it re-runs "Analysing Sheet" for a second time.
- In fact, this 'Analyzing Sheet' message may never disappear (it may stay on the screen forever / constantly).
Cause
There are many possible causes for slow performance when running Excel link reports.
- TIP: For more examples, see separate IBM Technote #1347497.
This Technote specifically relates to the scenario where the cause is a limitation in Excel 2013, related to calculation mode (automatic or manual).
More Information:
By default, Excel spreadsheets are set to have their calculations configured to be 'Automatic':
This has been seen (see third-party non-IBM link below) to cause slow performance for other (non-IBM) software, when using Excel 2013 (compared to Excel 2010, for example).
Environment
Client device has Excel 2013 (or later) installed.
Resolving The Problem
Modify the report's calculation mode from the default ('automatic') to 'manual'.
Steps:
The following must be done on an individual (per spreadsheet) basis:
1. Open spreadsheet (XLSX file)
2. Click 'Formulas'
3. Change 'Calculation Options' to: Manual
4. Save spreadsheet
5. Test.
Related Information
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Document Information
Modified date:
15 June 2018
UID
swg22006150