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Siebel Adapter business service not generating output XML

Troubleshooting


Problem

The outbound Siebel Adapter business service is not generating the output XML.

Cause

The reason the Siebel Adapter is not returning any XML is because of the Business Service Method Arg name that was used in Siebel Business Service. WebSphere Process Server (WPS) expects the output field name to be ?SiebelMessage?.

The following is the error line from the trace file:
11/2/10 17:46:01:173 CDT] 00000048 SEBLRA001 com.ibm.j2ca.siebel.SiebelBusServiceASIRetriever isSiebelMessage
SiebelMessage string value : false

The SiebelMessage string value in outputxml is set to false.

According to product documentation, WPS version before 6.2 requires the attribute to be named as Siebel Message. From version 6.2 and onward WPS supports any custom attribute name.

Resolving The Problem

Set the SiebelMessage string value in outputxml to true.

Change the value of one ASI to fix this problem. Check the following

1. Open the properties View, right click and select "Show In"->"Properties View".

2. Change the text value from "false" to "true", and try the runtime again.

[{"Product":{"code":"SSMKUK","label":"WebSphere Adapters Family"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Adapter for Siebel","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.1","Edition":"WebSphere","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
15 June 2018

UID

swg21456496