Troubleshooting
Problem
After replacing the system board on an IBM Smart Analytics System 7700 clustered node, the node cannot mount network shared disk resources using General Parallel File System (GPFS) .
Symptom
GPFS fails when attempting to mound network shared disks for the files systems; such as /dev/db2homefs or /dev/homefs.
Cause
After a system board replacement the Host Ethernet adapter's "Maximum receiving packet size" is set to 1500 Maximum Transmission Unit (MTU) and flow controls are disabled.
Diagnosing The Problem
When this problem occurs the mmfs.log log shows errors similar to the following after an attempt to mount the GPFS resource /dev/db2homefs:
Thu Jan 30 10:32:27.093 2014: Command: mount db2homefs 9437684
Thu Jan 30 10:32:27.113 2014: Command: err 46: mount db2homefs 9437684
Thu Jan 30 10:32:27.131 2014: GPFS: 6027-784 Device not ready. GPFS: 6027-510 Cannot mount /dev/db2homefs on /db2home: The device is not ready for operation.
Thu Jan 30 10:32:27 EST 2014: finished mounting /dev/db2homefs
An unresponsive ping of a large packet ping, that is 9000 bytes, from one node to another over the IBM Smart Analytics System 7700's internal application network also confirms the problem. The following is an example of an unresponsive large packet ping:
- # ping 172.23.1.11 9000
PING 172.23.1.11: (172.23.1.11): 9000 data bytes
This problem is seen in the output from the console command "errpt -a" output. The following errpt -a output shows the problem:
LABEL: HEA_JUMBO_FRAMES
IDENTIFIER: AB08F981
Date/Time: Sun Mar 2 13:37:30 GMT+09:00 2014
Sequence Number: 85827
Machine Id: 00F6BB314C00
Node Id: bstky01awd06
Class: H
Type: INFO
WPAR: Global
Resource Name: ent0
Resource Class:
Resource Type:
Location:
VPD:
IBM Host Ethernet Adapter:
Network Address.............5CF3FC0159E0
Description
HEA PHYSICAL PORT JUMBO FRAMES
Recommended Actions
Verify HEA physical port configuration in HMC
Detail Data
FILE NAME
line: 1268 file: hea_config.c
SENSE DATA
0000 0000 0000 0000 0000 005A 0061 0812 0000 0000 0000 0000 0000 0000
0001 8000
0000 0300 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000
0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000 0000
0000 0000
DEVICE DRIVER INTERNAL STATE
1111 1111 0000 0000 0000 0000 0000 0000 0000 0001
SOURCE ADDRESS
5CF3 FC01 59E0
Resolving The Problem
Resolve this problem by logging into the IBM Smart Analytics System 7700's Hardware Management Console; then navigate down the breadcrumb path "server CEC --> Hardware Information --> Adapter --> Host Ethernet".
On the Host Ethernet page do the following for each ethernet adapter:
- Enable "Transmission Flow Control" .
- Enable " Receive Flow Control".
- Set "Maximum receiving" to 9000.
Click on the following image to see an example of the correct settings:

Once the settings have been changed use the follow steps to recycle the node:
- shutdown the operating system
- power down the node
- power up the node
- restart operating system
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Document Information
Modified date:
16 June 2018
UID
swg21664133