IBM Support

Setting the TIP webcontainer to synchronous data transfer mode

Troubleshooting


Problem

Addressing Out of Memory exceptions might require setting the Websphere "channelwritetype" property to use synchronous data transfer (sync). This note includes the steps required to set the "channelwritetype" property in Tivoli Integrated Portal.

Cause

In the course of troubleshooting "OutOfMemory" related errors from applications deployed in Tivoli Integrated Portal (TIP), IBM Support may suggest enabling synchronous data transfer for the TIP webcontainer. The following Websphere technical note includes more detail on the use of the "channelwritetype" to control synchronous or asynchronous modes. However, since the TIP admin console does not provide all of the capabilities of the full WAS admin console, the instructions in that note for enabling synchronous data transfer are not applicable to TIP.

"Setting the WebSphere Application Server WebContainer to synchronous mode"
http://www-01.ibm.com/support/docview.wss?uid=swg21317658

Resolving The Problem

To set the "channelwritetype" property to use synchronous data transfer in TIP use the following wsadmin commands:

  1. Make a backup copy of the server.xml file located under:

    <TIP HOME>/profiles/TIPProfile/config/cells/TIPCell/nodes/TIPNode/servers/server1

    For example, make a copy called "server.xml.bak"

  2. Start an interactive wsadmin session using the wsadmin script found under <TIP HOME>/bin:

    Windows: wsadmin.bat -lang jacl
    Unix: ./wsadmin.sh -lang jacl
  3. Enter the following wsadmin commands:

    set myServer [$AdminConfig getid /Server:server1/]

    set webcontainer [$AdminConfig list WebContainer $myServer]

    $AdminConfig create Property $webcontainer {{name com.ibm.ws.webcontainer.channelwritetype} {value sync}} properties

    $AdminConfig show $webcontainer

    $AdminConfig save

    exit
  4. Restart the TIP server process for the change to be picked up.


To revert the change:
  1. Restore the backup copy of the server.xml you created under:
    <TIP HOME>/profiles/TIPProfile/config/cells/TIPCell/nodes/TIPNode/servers/server1

  2. Restart the TIP server process for the original server.xml file to be picked up.

[{"Product":{"code":"SSRLR8","label":"Tivoli Components"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Tivoli Integrated Portal (TIP)","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.1;2.1;2.2","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

More support for:
Tivoli Components

Software version:
1.1, 2.1, 2.2

Document number:
460271

Modified date:
17 June 2018

UID

swg21567746

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