IBM Support

Server will not start and states "Disk Full" in db2diag log

Troubleshooting


Problem

A Tivoli Storage Manager server on Linux fails to start up after halting and messages in the db2diag.log show "DIA8312C Disk was full"

Cause

By default Linux reserves 5% of each EXT file system for root use. If the Storage Manager server fills each of the file systems provided for the database to near 95%, it will fail to start as the operating system will return that it does not have enough free space to continue.

Environment

Linux

Diagnosing The Problem

Looking in the db2diag.log will show messages from the OS stating there is no space and the disk is full.


2015-05-10-05.37.52.762004-240 E1885E1315 LEVEL: Error (OS)
PID : 12999 TID : 47127644333824 PROC : db2sysc 0
INSTANCE: tsminst1 NODE : 000 DB : TSMDB1
APPHDL : 0-483 APPID: *LOCAL.tsminst1.150509212923
AUTHID : TSMINST1 HOSTNAME: system.ibm.com
EDUID : 517 EDUNAME: db2agent (TSMDB1) 0
FUNCTION: DB2 UDB, oper system services, sqloseekwrite64, probe:40
MESSAGE : ZRC=0x850F000C=-2062614516=SQLO_DISK "Disk full."
DIA8312C Disk was full.
CALLED : OS, -, pwrite OSERR: ENOSPC (28)
DATA #1 : File handle, PD_TYPE_SQO_FILE_HDL, 8 bytes


2015-05-10-05.37.52.807263-240 I8893E717 LEVEL: Error
PID : 12999 TID : 47127644333824 PROC : db2sysc 0
INSTANCE: tsminst1 NODE : 000 DB : TSMDB1
APPHDL : 0-483 APPID: *LOCAL.tsminst1.150509212923
AUTHID : TSMINST1 HOSTNAME: system.ibm.com
EDUID : 517 EDUNAME: db2agent (TSMDB1) 0
FUNCTION: DB2 UDB, buffer pool services, sqlbDMSAddContainerRequest,
probe:865
MESSAGE : ZRC=0x850F000C=-2062614516=SQLO_DISK "Disk full."
DIA8312C Disk was full.
DATA #1 : <preformatted>
Error acquiring container 16
(/home/tsminst1/db1/tsminst1/NODE0000/TSMDB1/T0000016/C0469788.LRG) for tbsp 16. Rc = 850F000C

File System Information of the target file :
Block size = 4096 bytes
Total size = 270560923648 bytes
Free size = 16994304 bytes
Total # of inodes = 16777216
FS name = /dev/mapper/tsminst1_db1
Mount point = /home/tsminst1/db1

Looking at the file system information provided in the log or df output will show there is very little free space left in the file system. The total size will also be 5% less than expected.

If additional database space was recently added to the server, it is likely the space has not yet been used or the database has not had time to rebalance. While there may be free space available for the database on the new file systems, free space is still required on the older ones for the server to start up correctly.

Resolving The Problem

It is possible to allow non root users to use the 5% reserved space by using the tune2fs command to remove this reserve.

Example: tune2fs -m 0 /dev/mapper/tsminst1_db1

This may need to be done for each file system the database resides on.

Once this is done the server should have some additional space to use when starting up. This free space can now be seen via the output from the df command. It is important at this time to create and add more space (via the extend db command) to the database immediately and rebalance the database to use the new space. If desired use the tune2fs command to put the reserved space back in place once new space has been added.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF016","label":"Linux"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

YSM

Document Information

Modified date:
17 June 2018

UID

swg21964502