IBM Support

Server upgrade wizard ends while EXTRACTDB and INSERTDB processes run

Troubleshooting


Problem

Using the Tivoli Storage Manager wizard for server upgrade from a remote console to perform the upgrade to V6 or V7, the upgrade wizard ends but the EXTRACTDB and INSERTDB processes continue run.

Cause

Working as designed

Diagnosing The Problem

When running the server upgrade wizard from a remote console, the remote console stops because of a connection reset. The EXTRACTDB and INSERTDB processes are still running. For example :

# ps -ef|grep dsmserv
tsminst1 446682 684224 87 16:01:18 - 113:20 /opt/tivoli/tsm/server/bin/dsmserv INSERTDB
root 663694 1 0 16:01:34 - 3:25
/usr/tivoli/tsm/upgrade/bin/dsmupgrd EXTRACTDB HLADDRESS=x.x.x.x
LLADDRESS=1500

Resolving The Problem

The Tivoli Storage Manager upgrade wizard is used to start the INSERTDB and EXTRACTDB processes, and display the upgrade progress messages in the wizard console. If for any reason the wizard ends while the INSERTDB and EXTRACTDB processes are still running, you can allow the upgrade processes to continue without the wizard. Monitor the progress of the upgrade by viewing the Extract.Out and InsertDB.Out files under the instance directory.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"All Supported Versions","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

Modified date:
17 June 2018

UID

swg21416872