IBM Support

Server upgrade fails due to DB2 upgrade problem

Troubleshooting


Problem

An active wmiprvse process prevents DB2 from upgrading.

Cause

The wmiprvse.exe process could not be stopped, causing a DB2 upgrade failure, which in turn causes the Tivoli Storage Manager server upgrade failure.

Diagnosing The Problem

The installation will indicate that the DB2 component fails to upgrade but no other useful messages. Review the db2_inst.log for additional logging. db2_inst.log can be found in the following location:

For server V6, it will be included in the logs.zip file created by the COI installer where the server is installed. The path to this file is logs.zip\coi\plan\logs\db2_inst.log.

For server V7, the path to this file is C:\ProgramData\IBM\Installation Manager\logs\native\tsm_logs\db2_install.log.

This file will have more logging information on the db2 installation. For this particular instance, the following message was logged:


1: The current directory for the process has now been changed to
C:\Users\ADMINI~1\AppData\Local\Temp\_DB20005
1: Loaded all install helper DLLs successfully.
1: Successfully enabled tracing.
1: The following process(es) could not be stopped:
wmiprvse.exe (PID=4396)

1: Failed to kill active DB2 processes prior to additional DB2
functionality being installed.
CustomAction DeferredKillProcessesCA returned actual error code 1603
(note this may not be 100% accurate if translation happened inside
sandbox)
Action ended 17:56:13: InstallFinalize. Return value 3.
....
MSI (s) (0C:28) [17:56:13:908]: Product: DB2 Enterprise Server Edition -
DB2TSM1 -- Configuration failed.
MSI (s) (0C:28) [17:56:13:908]: Windows Installer reconfigured the
product. Product Name: DB2 Enterprise Server Edition - DB2TSM1. Product
Version: 9.7.500.703. Product Language: 1033. Manufacturer: IBM.
Reconfiguration success or error status: 1603.
----------------------------------------------

Resolving The Problem

To fix this problem, do the following:
Option 1:
1. Open the cmd prompt with administrator privileges

2. Run the following command: "net stop winmgmt"

3. Run the installation/upgrade again.

4. To start the Windows Management Instrumentation again run the following command: "net start winmgmt"

Option 2:

1. If DB2 service is running, stop the service. If there are difficulties stopping the service, use:

db2stop force

2. Verify the WMI service is stopped.

3. Verify the process named wmiprvse.exe does not exist in Windows Task Manager. If it does, kill it.

4. Change the start mode for the service Windows Management Instrumentation to Disable.

5. Go to directory C:\Windows\System32\Wbem and rename the file wmiprvse.exe to something else.


If renaming wmiprvse.exe fails with invalid permissions from TrustedInstaller, proceed to step 5

6. Run the installation/upgrade again.

7. Rename the file wmiprvse.exe back to its original name after the installation/upgrade succeeds.

8. Change back the start mode for the service Windows Management Instrumentation to Automatic that had been Stopped and Disabled


[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Server","Platform":[{"code":"PF033","label":"Windows"}],"Version":"6.3;7.1","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Document Information

More support for:
Tivoli Storage Manager

Software version:
6.3, 7.1

Operating system(s):
Windows

Document number:
483691

Modified date:
06 March 2019

UID

swg21616960