IBM Support

Server session can time-out during Oracle database backup.

Troubleshooting


Problem

When running a backup session to the server, under certain conditions the commtimeout values will be exceeded resulting in the backup failing. No errors are seen in the RMAN logs to suggest a problem with the Oracle database.

Symptom

Unexpected backup termination with a common time duration before failure.

Cause

During a Oracle backup, an API session is opened with the backup server and a backup transaction is started. Oracle tables spaces are sparse files and can contain large regions of null blocks. Oracle/RMAN scans threw these blocks, but no data during this time is sent to the backup server via the API. If the time it takes Oracle/RMAN to process this sparse data exceeds the value set for COMMTIMEOUT then the session will time-out resulting in a failed backup.

Diagnosing The Problem

Customer can expect to see ANR0480W (Connection severed) messages for the failing node in the Tivoli Storage Manager server activity log.

Resolving The Problem

To avoid this problem it is recommended to set COMMTIMEOUT to 600 - 1200 seconds for Oracle backup nodes.

[{"Product":{"code":"SSTFZR","label":"Tivoli Storage Manager for Databases"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for Oracle","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"Version Independent","Edition":"Edition Independent","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM TDPO IBM Spectrum Protect

Document Information

Modified date:
17 June 2018

UID

swg21506291