IBM Support

Server service fails to start with “The system cannot find the file specified” error

Troubleshooting


Problem

The server service fails to start with an error 2. This error can occur after the service is stopped or after a reboot.

Symptom

The service fails with error 2.

image 7747
Windows® could not start the <service_name> service on local Computer.
Error 2: The system cannot find the file specified.

Cause

Looking in the registry path HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\<instance_name>\ the ImagePath value is in double quotation marks.
"C:\PROGRA~1\Tivoli\TSM\Server\dsmsvc.exe -k SERVER1"

Resolving The Problem

Removing the quotes from the ImagePath registry value allows the service to start normally.

Document Location

Worldwide

[{"Line of Business":{"code":"LOB26","label":"Storage"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"ARM Category":[{"code":"a8m0z000000GpK2AAK","label":"Server->Troubleshooting"}],"ARM Case Number":"TS004734390","Platform":[{"code":"PF033","label":"Windows"}],"Version":"All Version(s)"}]

Document Information

Modified date:
26 January 2021

UID

ibm16398887