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"Server is not reachable or still initializing, please refresh the page in a few seconds ... CCR WS API not initialized yet [error=2 counts of InaccessibleWSDLException]" error launching Controller Web, caused by IIS Windows authentication

Troubleshooting


Problem

User launches Controller Web. An error appears.

Symptom

image-20181214110038-1

Server is not reachable or still initializing, please refresh the page in a few seconds

Cause

There are many possible causes for this generic error.
  • TIP: See separate IBM Technote #791129 for more examples.
This Technote specifically relates to the scenario where the cause is that the JAVA-based Controller Web service cannot contact the Controller application server website (CCRWS.ASMX), because of authentication problems.
  • Specifically, the Controller server website's authentication has been changed from 'anonymous' to 'Windows' authentication.

Environment

Controller application server's IIS (webserver) has been configured to use Windows (not the default 'anonymous') authentication.
  • Typically this is done to enable Single Sign On (SSO).
However, (to make SSO work) Windows authentication is only required for the Cognos Analytics (CA) portion, not the Controller server (CCRWS.ASMX) portion.
  • Therefore it is unnecessary to use Windows authentication for the CCRWS.ASMX portion.

Diagnosing The Problem

Browse to the 'backend' logs folder here:     <install location>\ccr_64\fcmweb\wlp\usr\servers\fcm.web\logs
  • Open the file 'com.ibm.cognos.fcm.log' and search for errors similar to the following examples:
  
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Example #1 (English):
image-20191205075758-1
CCR WS API not initialized yet [error=2 counts of InaccessibleWSDLException]
  
Example #2 (German):
[ERROR   ] SRVE0283E: Es wurde eine Ausnahme beim Initialisieren des Kontextes abgefangen: java.lang.RuntimeException: [CCR WS] CCR WS API cannot be started: java.lang.RuntimeException: The CCR WS API [http://servername/ibmcognos/controllerserver/ccrws.asmx] initialization reached maximum allowed time (3600000 ms).
at com.ibm.cognos.fcm.wmc.ccrws.DefaultCcrClientFactory.initialize(DefaultCcrClientFactory.java:90)
at com.ibm.cognos.fcm.web.ui.infrastructure.CcrWsApiInitializer.run(CcrWsApiInitializer.java:50)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
 
Also, inside Task Manager (on the Controller application server), the process 'javaw.exe' seems to run for a very long time many minutes):
image-20191205080105-1

Resolving The Problem

Reconfigure the Controller-related IIS portion to use anonymous authentication.
  • However, leave the Cognos Analytics (CA) IIS portion to still use Windows authentication.
   
Steps:
1. Logon to the Controller application server
2. Launch Internet Information Services (IIS) Manager
3. Expand 'Default Website' until (eventually) you can highlight:   controllerserver
4. On the right-hand side, double-click on 'Authentication':
image-20190717164114-1
5. Enable "Anonymous Authentication"
6. Disable "Windows Authentication":
image-20190717164310-2
7. Restart both Controller Web services:
image-20191205080451-28. Test.

Document Location

Worldwide

[{"Business Unit":{"code":"BU002","label":"Business Analytics"},"Product":{"code":"SS9S6B","label":"Cognos Controller"},"Component":"","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.4.1","Edition":""}]

Document Information

Modified date:
01 April 2020

UID

ibm11125087