Troubleshooting
Problem
Server fails to initialize and displays the following error message: ANR9999D_1392833238 AdmSetupAdminSQL(adminit.c:6318) Thread<0>: Error 11 creating view SERVERGROUP
Symptom
The following errors will be displayed when attempting to start the Tivoli Storage Manager server in the foreground.
ANR0110E An unexpected system date has been detected; the server is disabled. Verify the system date and use the ACCEPT DATE command to establish the current date as valid.
ANR9999D_1392833238 AdmSetupAdminSQL(adminit.c:6318) Thread<0>: Error 11 creating view SERVERGROUP
ANR1912I Stopping the activity log because of a server shutdown
*Note that the view listed in the error message may be something different than SERVERGROUP.
Cause
When the Tivoli Storage Manager Server instance is restarted, specific administrative SQL views are deleted and then redefined in the database in order to resynchronize them. Changing the system time to an earlier time than the object creation time will result in some objects becoming inaccessible, causing the server initialization to fail.
Diagnosing The Problem
If a clear indication of the problem is not evident in Tivoli Storage Manager Server tracing or the db2diag.log, the error messages displayed during startup should be reviewed to determine a match for this problem.
Resolving The Problem
Perform the following steps to resolve this situation:
1) Open a DB2 command window.
- For Windows operating systems:
- For Unix operating systems:
(Start -> IBM DB2 -> DB2TSM1 -> Command Line Tools -> Command Window)
db2cmd
3) db2 "update db cfg for TSMDB1 using AUTO_REVAL DISABLED IMMEDIATE"
4) db2stop
5) Restart the Tivoli Storage Manager Server
6) Issue the 'accept date' command
Product Synonym
TSM
Was this topic helpful?
Document Information
Modified date:
17 June 2018
UID
swg21578673