IBM Support

Server down due to ASSERTION FAILURE IN JCLEXCEPTION

Troubleshooting


Problem

Running IBM Collaborative Lifecycle Management (CLM) after upgrading Java version for IBM Websphere Application Server (WAS) results in a system down.

Symptom

Java version used by WAS is upgraded to JRE 1.8.0 Windows Server 2016 amd64-64 (build 8.0.6.0 - pwa6480sr6-20191107_01(SR6)).

Cause

There is a defect in the Java version you have upgraded to:
https://www.ibm.com/support/pages/apar/IJ23367

Environment

CLM running on WAS with Java version:
JRE 1.8.0 Windows Server 2016 amd64-64 (build 8.0.6.0 - pwa6480sr6-20191107_01(SR6))

Diagnosing The Problem

Open one of the java cores and look for the following errors:
dump routine contain a traceassert reported.
 Dump Event "traceassert" (00080000) received

 j9jcl.191 - * ** ASSERTION FAILED ** at common/jclexception.c:263: ((string) != NULL)

Resolving The Problem

Upgrade your Java to version 8 SR6 FP10 (8.0.6.10), which is the version in which the defect is fixed, once that version is available.
See the relevant APAR record for reference: https://www.ibm.com/support/pages/apar/IJ23367
WORKAROUND:
Avoid upgrading your Java to the affected versions.

Document Location

Worldwide

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Document Information

Modified date:
06 April 2020

UID

ibm16132027