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Security Services Error: No credentials cache found error seen in IIB trace when using Windows Authentication with ODBC Data Direct adapter

Troubleshooting


Problem

Security Services Error: No credentials cache found error seen in IIB trace when using Windows Authentication with ODBC Data Direct adapter.

Symptom

Security Services Error: No credentials cache found error seen in IIB trace when using Windows Authentication with ODBC Data Direct adapter.

Cause

ITX uses a third party DataDirect ODBC driver to connect to MS SQL on non-Windows environment. The following shows that DataDirect does not support NTLM on Linux: In the odbc\help subdirectory of the ITX install, double click on help.htm and then search on NTLM. In the search results click on "Using Security" and in there is a statement of "On Windows platforms only, NTLM authentication is available with the SQL Server Wire Protocoldriver and the driver for the Teradata database." in the "Kerberos and NTLM Authentication" section.

Environment

Non-Windows environment.

Diagnosing The Problem

Enable database/IIB trace to see Security Services Error: No credentials cache found error

Resolving The Problem

With Kerberos, modify the SQL Server Wire Protocol stanza in the odbc.ini file to have AuthenticationMethod=10 (which is NTLMv2) and to use the T4sqls25 driver.

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Product Synonym

Websphere Transformation Extender
Message Broker
ACE
IIB

Document Information

More support for:
IBM Transformation Extender

Software version:
All Versions

Operating system(s):
Linux

Document number:
792435

Modified date:
02 March 2020

UID

ibm10792435