IBM Support

Security Bulletin: A vulnerability in util-linux affects PowerKVM (CVE-2016-5011)

Security Bulletin


PowerKVM is affected by a vulnerability in the util-linux package's libblkid library. IBM has now addressed this vulnerability.

Vulnerability Details

CVEID: CVE-2016-5011
Util-linux is vulnerable to a denial of service, caused by an error when parsing Master Boot Record (MBR) record. By connecting a device with a specially-crafted Master Boot Record (MBR) record, a local attacker could exploit this vulnerability to cause the system to become unresponsive.
CVSS Base Score: 4.6
CVSS Temporal Score: See for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:P/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H)

Affected Products and Versions

PowerKVM 2.1 and PowerKVM 3.1.


Customers can update PowerKVM systems by using "yum update".

Fix images are made available via Fix Central. For version 3.1, see This issue is addressed as of update 3 or later.

For version 2.1, see This issue is addressed as of PowerKVM update 13 or later. Customers running v2.1 are, in any case, encouraged to upgrade to v3.1.

For v2.1 systems currently running fix levels of PowerKVM prior to 2.1.1, please see for prerequisite fixes and instructions.

Get Notified about Future Security Bulletins



Change History

6 November 2016 - Initial Version

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.


According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

[{"Product":{"code":"SSZJY4","label":"PowerKVM"},"Business Unit":{"code":"BU054","label":"Systems w\/TPS"},"Component":"Not Applicable","Platform":[{"code":"PF016","label":"Linux"}],"Version":"2.1;3.1","Edition":"KVM","Line of Business":{"code":"LOB08","label":"Cognitive Systems"}}]

Document Information

Modified date:
17 June 2018