IBM Support

Security Bulletin: Vulnerabilities in OpenSSL affect IBM Integration Bus and IBM App Connect Enterprise v11 & v12 (CVE-2021-3711)

Security Bulletin


Summary

Vulnerabilities in OpenSSL affect IBM Integration Bus and IBM App Connect Enterprsie. The DataDirect ODBC Drivers & Nodejs used by IBM App Connect Enterprise and IBM Integration Bus have addressed the applicable CVEs

Vulnerability Details

CVEID:   CVE-2021-3711
DESCRIPTION:   OpenSSL is vulnerable to a buffer overflow, caused by improper bounds checking by the EVP_PKEY_decrypt() function within implementation of the SM2 decryption. By sending specially crafted SM2 content, a remote attacker could overflow a buffer and execute arbitrary code on the system or cause the application to crash.
CVSS Base score: 9.8
CVSS Temporal Score: See: https://exchange.xforce.ibmcloud.com/vulnerabilities/208072 for the current score.
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H)

Affected Products and Versions

IBM Integration Bus V10.0.0 - V10.0.0.25

IBM App Connect Enterprise V11 , V11.0.0.0 - V11.0.0.15

IBM App connect Enterprise V12.0.1.0 - V12.0.2.0

 

Remediation/Fixes

1. IT38663 addresses the DataDirect ODBC driver which is affected by CVE-2021-3711

2. IT38613 addresses the version of node js which is affected by CVE-2021-3711

 

Product
VRMF
APAR
Remediation / Fix
IBM App Connect Enterprise V12V12.0.1.0 - V12.0.2.0IT38663
 
Interim fix for APAR (IT38663) for 12.0.2.0 is available from  IBM Fix Central
 
 
IBM App Connect Enterprise V12V12.0.1.0IT38613
The APAR (IT38613)  is available in fix pack 12.0.2.0
IBM App Connect Enterprise v11V11.0.0.0-V11.0.0.15IT38663
 
Interim fix for APAR (IT38663) for 11.0.0.15 is available from IBM Fix Central
 
Interim fix for APAR (IT38663) for 11.0.0.14 is available from IBM Fix Central
IBM App Connect Enterprise v11V11.0.0.0-V11.0.0.14IT38613
The APAR (IT38613)  is available in fix pack 11.0.0.15
IBM Integration Bus V10.0.0.0 - V10.0.0.24 IT38663
 
Interim fix for APAR (IT38663) for 10.0.0.24 is available from
 
 
 
IBM Integration Bus V10.0.0.0 - V10.0.0.25IT38613
 See section Workarounds and Mitigations

 

Workarounds and Mitigations

For IBM Integration Bus v10 V10.0.0.24 -V10.0.0.25 users can disable node js. Refer to
'Disabling Node.js in IBM Integration Bus 10.0.0.24 and subsequent v10.0 fix packs'

Get Notified about Future Security Bulletins

References

Off

Acknowledgement

Change History

20 Oct 2021: Initial Publication

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Document Location

Worldwide

[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSDR5J","label":"IBM App Connect Enterprise"},"Component":"-","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF002","label":"AIX"},{"code":"PF033","label":"Windows"}],"Version":"-","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
28 March 2022

UID

ibm16520342