IBM Support

Security Bulletin: Multiple vulnerabilities in IBM QRadar SIEM (CVE-2014-0838, CVE-2014-0835, CVE-2014-0836, CVE-2014-0837)

Security Bulletin


Summary

Multiple vulnerabilities exist in the AutoUpdate settings page and the AutoUpdate process within the IBM QRadar SIEM that when used together could result in remote code execution.

Vulnerability Details

VULNERABILITY DETAILS:

CVE ID:
CVE-2014-0838

DESCRIPTION: A flaw in the IBM QRadar Security Information and Event Management (SIEM) AutoUpdate process could allow for remote commands to be run on the console. The server first needs to be either compromised or changed to the attacker's server by the way of the Cross-Site Request Forgery (CVE-2014-0835), Cross-Site Scripting (CVE-2014-0836) or the Incorrect Handling of SSL(CVE-2014-0837) described below. The attack does not require local network access or authentication but specialized knowledge and techniques are required. An exploit can compromise the confidentiality of information, the integrity of data and availability of the system.

CVSS:
CVSS Base Score: 9.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/90681 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (AV:N/AC:M/Au:N/C:C/I:C/A:C)

AFFECTED PRODUCTS:
IBM QRadar Security Information and Event Manager (SIEM) 7.2 MR1 and earlier

REMEDIATION:
The vulnerability can be fixed in two ways, either by installing the latest AutoUpdate package, or install the relevant iFix or FixPack.

The vulnerability has been fixed in the following versions of QRadar SIEM:

  • For QRadar SIEM 7.2 – Install QRadar 7.2 MR1 Patch 2 Interim Fix 2
  • For QRadar SIEM 7.1 – Install QRadar 7.1 MR2 Patch 5
  • For QRadar SIEM 7.0 – Install QRadar 7.0 MR5 Patch 8


  • To install the latest AutoUpdate package to fix this vulnerability please do the following:
  • Open a new broswer session ensuring that all other websites are closed.
  • Navigate to the QRadar Console IP and log into the system as an administrator.
  • Open the Admin tab, and click the 'Auto Update' button under 'System Configuration'.
  • Once the Auto Update settings page appears click 'Change Settings' and click the 'Advanced' tab.
  • Ensure that the proper 'Web Server' (default: https://qmmunity.q1labs.com/) and 'Directory' (default: autoupdates/).
  • Once the settings are verified, navigate to 'Check fo Updates', and click on the 'Get New Updates' button.
  • Wait while the Auto Update runs. You should see a notification once the update has been completed.
  • To verify that the patch has been installed view the /var/log/qradar.log file and look for a line similar to the following:


  • Jan 28 10:07:04 qradar AUTOUPDATE[4986]: Required version is 6.4 We are running 6.3
    Jan 28 10:07:04 qradar AUTOUPDATE[4986]: Restarting with version 6.4.
    Jan 28 10:08:02 qradar AUTOUPDATE[8694]: Autoupdate 6.4 initialized.

    Version 6.4 of the Auto Update is the patched version for this vulnerability. This will fix all versions of QRadar.

    WORKAROUNDS:
    None

    MITIGATION:
    Automatic updates can be temporarily be disabled until a fix is available. As long as the appliance update settings cannot be modified through Cross-Site Request Forgery (CVE-2014-0835) or Cross-Site Scripting (CVE-2014-0836) this should prevent an exploit from taking effect.

    Once a fix is available customers can force an auto-update to address this issue after manually validating the update server. A manual patch will be also provided.

    If you turn off auto-update, you should continue to monitor this bulletin for updates to the remediation section to find information about the availability of the fix.


    CVE ID:
    CVE-2014-0835

    DESCRIPTION: A Cross-Site Request Forgery vulnerability has been discovered within the IBM QRadar Security Information and Event Management (SIEM) software. This vulnerability could allow an attacker to change the Auto Update settings of the QRadar console. The attack does not require local network access or authentication but specialized knowledge and techniques are required. An exploit would not impact the availability of the system or the confidentiality of information, however the integrity of data could be compromised.

    CVSS:
    CVSS Base Score: 4.3
    CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/90678 for the current score
    CVSS Environmental Score*: Undefined
    CVSS Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N)

    AFFECTED PRODUCTS:
    IBM QRadar Security Information and Event Manager (SIEM) 7.2 MR1 and earlier

    REMEDIATION:
    The vulnerability has been fixed in the following versions of QRadar SIEM:
  • For QRadar SIEM 7.2 – Install QRadar 7.2 MR1 Patch 2 Interim Fix 2
  • For QRadar SIEM 7.1 – Install QRadar 7.1 MR2 Patch 5
  • For QRadar SIEM 7.0 – Install QRadar 7.0 MR5 Patch 8



  • WORKAROUNDS:
    None

    MITIGATION:
    Do not visit other webpages with the web browser that you are using to access QRadar unless you are logged out of the QRadar application.
    Verify that all settings are correct and as desired before deploying your configuration.


    CVE ID:
    CVE-2014-0836
    DESCRIPTION: A Cross Site Scripting vulnerability has been discovered within the IBM QRadar Security Information and Event Management (SIEM) software. This vulnerability could allow an attacker to gain access to the administrative settings of the QRadar console. The attack does not require local network access or authentication but specialized knowledge and techniques are required. An exploit would not impact the availability of the system or the confidentiality of information, however the integrity of data could be compromised.

    CVSS:
    CVSS Base Score: 4.3
    CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/90679 for the current score
    CVSS Environmental Score*: Undefined
    CVSS Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N)

    AFFECTED PRODUCTS:
    IBM QRadar Security Information and Event Manager (SIEM) 7.2 MR1 and earlier

    REMEDIATION:
    The vulnerability has been fixed in the following versions of QRadar SIEM:
  • For QRadar SIEM 7.2 – Install QRadar 7.2 MR1 Patch 2 Interim Fix 2
  • For QRadar SIEM 7.1 – Install QRadar 7.1 MR2 Patch 5
  • For QRadar SIEM 7.0 – Install QRadar 7.0 MR5 Patch 8


  • WORKAROUNDS:
    None

    MITIGATION:
    Do not launch the QRadar application from links you received in an e-mail or from other untrusted sources.
    Verify that all settings are correct and as desired before deploying your configuration.



    CVE ID:
    CVE-2014-0837

    DESCRIPTION: The AutoUpdate process in the IBM QRadar Security Information and Event Management (SIEM) software does not verify the validity of the certificate passed during the initiation of its secure communication. This could allow an attacker to spoof the AutoUpdate Server with no warning to the administrator. The attack does not require local network access or authentication but does require specialized knowledge and techniques. An exploit would not impact the availability or confidentiality of the system, however the integrity of data could be compromised.

    CVSS:
    CVSS Base Score: 4.3
    CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/90680 for the current score
    CVSS Environmental Score*: Undefined
    CVSS Vector: (AV:N/AC:M/Au:N/C:N/I:P/A:N)

    AFFECTED PRODUCTS:
    IBM QRadar Security Information and Event Manager (SIEM) 7.2 MR1 and earlier

    REMEDIATION:
    To install the latest AutoUpdate package to fix this vulnerability please do the following:
  • Open a new browser session ensuring that all other websites are closed.
  • Navigate to the QRadar Console IP and log into the system as an administrator.
  • Open the Admin tab, and click the 'Auto Update' button under 'System Configuration'.
  • Once the Auto Update settings page appears click 'Change Settings' and click the 'Advanced' tab.
  • Ensure that the proper 'Web Server' (default: https://qmmunity.q1labs.com/) and 'Directory' (default: autoupdates/).
  • Once the settings are verified, navigate to 'Check for Updates', and click on the 'Get New Updates' button.
  • Wait while the Auto Update runs. You should see a notification once the update has been completed.
  • To verify that the patch has been installed view the /var/log/qradar.log file and look for a line similar to the following:


  • Apr 04 10:07:04 qradar AUTOUPDATE[4986]: Required version is 6.7 We are running 6.x
    Apr 04 10:07:04 qradar AUTOUPDATE[4986]: Restarting with version 6.7. 
    Apr 04 10:08:02 qradar AUTOUPDATE[8694]: Autoupdate 6.7 initialized. 

    WORKAROUNDS:
    None

    MITIGATION:
    Verify that all settings for the AutoUpdate are set correctly, and manually ensure that the site set as the update server is valid and trusted by opening the link in a browser or validating the IP address.

    Get Notified about Future Security Bulletins

    References

    Off

    Change History

    04 April 2014 - Remediation updated for CVE-2014-0837
    14 February 2014 - Remediation updated for CVE-2014-0838, CVE-2014-0835, CVE-2014-0836
    29 January 2014 - Remediation updated for CVE-2014-0838

    *The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

    Disclaimer

    According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY. In addition to other efforts to address potential vulnerabilities, IBM periodically updates the record of components contained in our product offerings. As part of that effort, if IBM identifies previously unidentified packages in a product/service inventory, we address relevant vulnerabilities regardless of CVE date. Inclusion of an older CVEID does not demonstrate that the referenced product has been used by IBM since that date, nor that IBM was aware of a vulnerability as of that date. We are making clients aware of relevant vulnerabilities as we become aware of them. "Affected Products and Versions" referenced in IBM Security Bulletins are intended to be only products and versions that are supported by IBM and have not passed their end-of-support or warranty date. Thus, failure to reference unsupported or extended-support products and versions in this Security Bulletin does not constitute a determination by IBM that they are unaffected by the vulnerability. Reference to one or more unsupported versions in this Security Bulletin shall not create an obligation for IBM to provide fixes for any unsupported or extended-support products or versions.

    Internal Use Only

    change history is not a rich text field

    [{"Product":{"code":"SSBQAC","label":"IBM Security QRadar SIEM"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.1;7.0;7.2","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

    Document Information

    Modified date:
    16 June 2018

    UID

    swg21663066