IBM Support

Security Bulletin: IBM MQ clients are vulnerable to a denial of service attack caused by consuming specifically crafted messages (CVE-2019-4261)

Security Bulletin


Summary

An error was found with the IBM MQ client message handling logic that causes a denial of service attack when specifically crafted messages are consumed.

Vulnerability Details

CVEID: CVE-2019-4261
DESCRIPTION: IBM MQ Clients are vulnerable to a denial of service attack caused by specially crafted messages.
CVSS Base Score: 4.3
CVSS Temporal Score: See https://exchange.xforce.ibmcloud.com/vulnerabilities/160013 for the current score
CVSS Environmental Score*: Undefined
CVSS Vector: (CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L)

Affected Products and Versions

IBM WebSphere MQ V7.1
versions 7.1.0.0 - 7.1.0.9
 
IBM WepSphere MQ V7.5
versions 7.5.0.0 - 7.5.0.9
IBM MQ V8
versions 8.0.0.0 - 8.0.0.11
 
IBM MQ V9.0LTS
versions 9.0.0.0 - 9.0.0.6
IBM MQ V9.1 LTS
versions 9.1.0.0 - 9.1.0.2
 
IBM MQ V9.1 CD
versions 9.1.0 - 9.1.2

Remediation/Fixes

IBM WebSphere MQ V7.1
Contact IBM Support to request a fix for APAR IT25916
 
IBM WepSphere MQ V7.5
Contact IBM Support to request a fix for APAR IT25916
IBM MQ V8
 
IBM MQ V9.0LTS
IBM MQ V9.1 LTS
 
IBM MQ V9.1 CD

Workarounds and Mitigations

None

Get Notified about Future Security Bulletins

References

Off

Change History

1st August 2019: Original version published

*The CVSS Environment Score is customer environment specific and will ultimately impact the Overall CVSS Score. Customers can evaluate the impact of this vulnerability in their environments by accessing the links in the Reference section of this Security Bulletin.

Disclaimer

According to the Forum of Incident Response and Security Teams (FIRST), the Common Vulnerability Scoring System (CVSS) is an "industry open standard designed to convey vulnerability severity and help to determine urgency and priority of response." IBM PROVIDES THE CVSS SCORES ""AS IS"" WITHOUT WARRANTY OF ANY KIND, INCLUDING THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE. CUSTOMERS ARE RESPONSIBLE FOR ASSESSING THE IMPACT OF ANY ACTUAL OR POTENTIAL SECURITY VULNERABILITY.

Internal Use Only

Advisory: 15956
Product Record: 135150

Document Location

Worldwide

[{"Business Unit":{"code":"BU004","label":"Hybrid Cloud"},"Product":{"code":"SSYHRD","label":"IBM MQ"},"Component":"client","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF012","label":"IBM i"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"8.0.0.0;8.0.0.1;8.0.0.2;8.0.0.3;8.0.0.4;8.0.0.5;8.0.0.6;8.0.0.7;8.0.0.8;8.0.0.9;8.0.0.10;8.0.0.11;9.0.0.0;9.0.0.1;9.0.0.2;9.0.0.3;9.0.0.4;9.0.0.5;9.0.0.6;9.1.0.0;9.1.0.1;9.1.0.2;9.1.1;9.1.2","Edition":"All"}]

Document Information

Modified date:
01 August 2019

UID

ibm10886887