Troubleshooting
Problem
In IBM Engineering Workflow Management (EWM) application, some SCM commands will fail if the RTC client is a version below than the server version and if using the workspace alias or UUID
Symptom
Known commands facing this issue:
scm delete workspace
scm load command
scm list flowtargets
When running some of the commands above, using workspace alias or UUID , RTC will not be able to identify the workspace, for example:
Using RTC Client version 6.0.6 with EWM version 7.
SCM
scm -u y list flowtargets -r https://<server url> <workspace UUID>
Problem running 'list flowtargets': Unmatched workspace <workspace UUID>"
Cause
There is a defect in this area:
https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=496047
https://jazz.net/jazz/web/projects/Rational%20Team%20Concert#action=com.ibm.team.workitem.viewWorkItem&id=511891
Environment
EWM server 7.0
RTC server 6.x
Resolving The Problem
As a workaround you can use the workspace name instead of the UUID or Alias.
This defect will be solved in EWM 7.0.2
Related Information
Document Location
Worldwide
[{"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Product":{"code":"SSUC3U","label":"IBM Engineering Workflow Management"},"ARM Category":[{"code":"a8m50000000CjThAAK","label":"Team Concert->Workflow"}],"ARM Case Number":"","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.0.0","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
Was this topic helpful?
Document Information
Modified date:
13 August 2020
UID
ibm16253311