Troubleshooting
Problem
Path failures occur for one or more LUNs/hdisks on AIX or Virtual IO Server.
Symptom
The AIX/ VIOS errpt log contains SC_DISK_ERR2 entry with Sense Data indicating 030F for the status validity and disk driver status fields.
Cause
The error occurs when an unspecified change on the storage side causes the LUN Serial Number previously provided to the host to be altered.
This typically involves some maintenance activity on the storage side.
Environment
AIX Server (all releases)
PowerVM Virtual IO Server (all releases)
Diagnosing The Problem
1. Download summ diagnostic tool on the server.
2. Examine errpt log as shown below.
errpt -a| summ
Oct 6 00:00:00 hdisk# P SC_DISK_ERR2 path 2 INQUIRY Serial number mismatch; Old: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxold_number00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000; New: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxnew_number00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 (0 Sec rtry 01)
Oct 6 00:00:00 hdisk# P SC_DISK_ERR2 path 1 INQUIRY Serial number mismatch; Old: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxold_number00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000; New: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxnew_number00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 (0 Sec rtry 01)
Oct 6 00:00:00 hdisk# P SC_DISK_ERR2 path 0 INQUIRY Serial number mismatch; Old: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxold_number00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000; New: xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxnew_number00000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000000 (0 Sec rtry 01)
3. SC_DISK_ERR2 Serial number mismatch error shows an INQUIRY command sent to the storage device returned a New Serial Number that did not match the Old Serial Number previously reported by the same LUN.
The error's Detailed Sense Data displays 030F as in the example below:
SENSE DATA
0600 1200 0000 FF00 0000 0000 0000 0000 0000 0000 0000 0000 030F 0000 3830 476E
0600 1200 0000 FF00 0000 0000 0000 0000 0000 0000 0000 0000 030F 0000 3830 476E
Resolving The Problem
To resolve the errors from a changed disk serial number on AIX and VIOS, remove the affected hdisk and rescan using cfgmgr command to rediscover the LUN:
# rmdev -dl hdisk#
# cfgmgr -l hdisk#
Need Further Assistance?
If the problem persists, please Open a case with IBM Support.
- Provide a good description of your issue and if any changes were made to the system.
- Collect and upload logs as instructed in Must-Gather Data for AIX I/O Device Drivers + MPIO Issues.
Document Location
Worldwide
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Document Information
Modified date:
21 July 2025
UID
ibm17172416