IBM Support

Saving a chart in IBM i2 Analyst's Notebook causes the program to freeze

Troubleshooting


Problem

Attempts to save a chart using IBM i2 Analyst's Notebook results in the program freezing, and in some cases taking an unusually long time to save the chart.

Symptom

This issue can also cause slow start up times in IBM i2 Analyst's Notebook.

Cause

This has been identified as a product defect under APAR PO01532. This issue is caused when the user's My Documents folder has been redirected to a network share.

Environment

User's My Documents folder is redirected to a network share (either manually, or via Group Policy).

Resolving The Problem

This issue has been resolved in version 8.9.7 of Analyst's Notebook. Upgrading to version 8.9.7 is the recommended fix for this issue. Alternatively, the following workarounds will resolve the issue:

Unchecking the 'Save Custom Icons In Charts' option (found in Tools > Options > Save) will resolve the issue.

Disabling the My Documents redirection, so that the folder reverts back to its original local location, will also resolve the issue. Alternatively, you can manually change the following registry keys so that they point to a local folder:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2\Analyst's Notebook 7\Image Directories\Icons\Custom Screen\Path

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\i2\Analyst's Notebook 7\Image Directories\Icons\Custom Printer\Path

[{"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9.5","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

Modified date:
16 June 2018

UID

swg21643858