Troubleshooting
Problem
The customer is attempting to upgrade the HMC and runs the Save Upgrade Data task resulting in an error HSCSAVEUPGRDATA_ERROR preventing the command from running successfully.
Symptom
The customer runs either the CLI command of saveupgdata -r disk | diskusb or the "Save Upgrade Data" task under HMC Management -> Console Management -> Save Upgrade Data.
After executing the command or task, the resulting error is displayed:
Save Upgrade Data
The following error occurred: There is no more space left on the upgrade partition. Please remove files saved in users' home directory and retry the operation.
HSCSAVEUPGRDATA_ERROR
Cause
Typically, some user or users have stored very large files in their /home directory that is exceeding the space in the /mnt/upgrade partition for Save Upgrade Data.
Environment
Any HMC Hardware appliance
Any Virtual HMC appliance
Any Version or Release of HMC
Diagnosing The Problem
Check the file saveUpgradeFiles.log:
tail /var/hsc/log/saveUpgradeFiles.log
/home/hscroot/HMClogs.hmc0709160940.zip /home/hscroot/HMClogs.hmc0712140658.zip An error occurred while executing the 'tar' command, rc=2 unmount of /mnt/upgrade. RC = 0 Upgrade partition is full umount: /mnt/upgrade: not mounted Can't unmount the source /mnt/upgrade, rc = 32. saveUpgradeFiles script exiting, rc = 10.
Resolving The Problem
Login to the HMC as the user with the large files that were displayed at the end of the /var/hsc/log/saveUpgradeFiles.log file and remove them.
rm /home/hscroot/HMClogs.hmc0709160940.zip rm /home/hscroot/HMClogs.hmc0712140658.zip Retry the Save Upgrade Data task.
If the log file is not obvious as to what file is large and for what user, check each user's home directory for large files such as vios images, HMC iso images, or pedbg files, etc. Remove any unnecessary files or move the files to the proper paths with more space.
Document Location
Worldwide
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Document Information
Modified date:
29 March 2022
UID
ibm16564047