IBM Support

SAP HANA delete of backup with backint doesn't work

Troubleshooting


Problem

Running a SAP HANA deletion command fails to remove the backups from the Tivoli Storage Manager Server.

Cause

There are some backups requested for deletion which are no longer existing on the Tivoli Storage Manager Server.

Diagnosing The Problem

Check the backup.log file for NOTFOUND messages for any of the deletions.

For example:

    DELETE backint error: BACKINT delete job for /usr/sap/PRD/SYS/global/hdb/backint/log_backup_0_0_0_0 with
    ebid PRD___A1BC2D3EFG failed with error code NOTFOUNDBACKINT

Resolving The Problem

When running a deletion job for SAP HANA backups, either in the SAP HANA Studio or with the hdbsql command, the SAP HANA error handling prevents the start of the deletion job when some of the objects are queried and return #NOTFOUND. This type of failure can occur when some files have been deleted from the Tivoli Storage Manager server even if others still exist.

As a workaround, the backup files can be removed from the Tivoli Storage Manager server directly (external to SAP HANA) using the command:

    "hdbbackint -f delete -p initSID.utl"
At the prompt, the IDs of the backups subject to deletion can be entered.

This problem was found to be a defect within SAP HANA and will be fixed in Revision 72 or 73. This problem does not affect the restore functionality for the existing backups.

[{"Product":{"code":"SSZHVN","label":"Tivoli Storage Manager for Enterprise Resource Planning"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Data Protection for SAP HANA\u00ae","Platform":[{"code":"PF016","label":"Linux"}],"Version":"Version Independent","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21678403