Troubleshooting
Problem
This technote identifies potential resolutions to the error, Word cannot open this document template, which might occur when opening a Microsoft® Word document from within IBM® Rational® RequisitePro®.
Cause
The full error message is as follows:
Runtime error: Word cannot open this document template. - Template:
C:\Program Files TermServer\Rational\RequisitePro\bin\REQPRO10.DOT
(RqWordServices.WordWrapper,248,5180)(RqWordServices.WordWrapper,431,1)
This error has been known to occur when RequisitePro installation files are missing such as the ReqPro10.dot from the bin folder. The ReqPro10.dot file is needed to open or create any document from within RequisitePro.
Another possible cause to for this error is that files included in the sample databases in version 7.0.0.0 and version 7.0.0.1 are missing. This issue has been identified as a product defect and has been logged under APAR PK33488.
Resolving The Problem
These issue can be resolved using one of the following workarounds:
Copying the ReqPro10.dot from another working system:
Copy ReqPro10.dot from another machine that has the exact same RequisitePro version and ifix version installed.
The ReqPro10.dot by default is located in the following directory:
<Install drive>:\Program Files\Rational\RequisitePro\bin
Once the file has been replaced, you should be able to open a Word document from within RequisitePro.
Perform a reinstall of RequisitePro with the Sample Databases:
- Perform an uninstall of RequisitePro using the procedure described in TN#1189855.
Install RequisitePro again and include the sample databases.
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Document Information
Modified date:
16 June 2018
UID
swg21260898