Troubleshooting
Problem
This technote identifies a potential resolution to the error, Runtime error: do: not understood, which might occur when opening a specific document in IBM® Rational® RequisitePro® (ReqPro).
Cause
The full error message is as follows:
Microsoft Visual Basic
Run-time error '1':
Invalid procedure call or
argument(ReqPro10.RebuildReqTags,260,5)(ReqPro10.RebuildReqTag"
The above error occurs repeatedly until End is selected as the Debug and Continue buttons are greyed out. After RequisitePro crashes the following error is found in the log:
Runtime error: "do:" not understood
Resolving The Problem
To resolve this issue perform the following:
Change the project properties so that the project documents can be opened in Microsoft® Word outside of RequisitePro:
- In RequisitePro select File > Project Administration > Properties
- On the Documents tab, uncheck the box Save documents in RequisitePro format.
- Exit RequisitePro
- Open problematic document in the project directory
- Select View > Toolbars > Reviewing
- In the Reviewing toolbar, click Show, and then make sure that a check mark appears next to each of the following items:
- Comments
- Ink Annotations (Word 2003 only)
- Insertions and Deletions
- Formatting
- Reviewers (Point to Reviewers and make sure that All Reviewers is selected.)
If a check mark does not appear next to an item, click the item to select it. - On the Reviewing toolbar, click Accept Change and drop down to Accept All Changes in Document.
Repeat last 2 steps until all the revisions in the document have been accepted or rejected and all the comments have been deleted. - Select Edit > Select All
- Select Edit > Copy
- Create a New Document
- Select Edit > Paste
- Close the problematic document
- Rename the problematic document with the extension of .OLD
- Save new document using the name of old document.
- In RequisitePro, change the project properties so that the project documents cannot be opened in Word outside of RequisitePro: File > Project Administration > Properties ...
On the Documents tab, check the box Save documents in RequisitePro format
This should resolve problem.
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21260176