IBM Support

Running a report from Report Management Portal results in Invalid Username/Password error

Troubleshooting


Problem

Attempts to run a report using the IBM Rational RequisitePro Report Management Portal results in the error "Username/Password Invalid".

Symptom

Correct credentials are entered in the IBM Rational RequisitePro Report Management Portal (http:///ReqProRptMgmt).

Running a report results in the following error:

Username/Password Invalid

Cause

This problem can be caused by a number of reasons:

  1. The project is not listed in the ReqWeb catalog (catalog.txt).
  2. The credentials entered to log in to the RequisitePro project are invalid.
  3. The browser has cached credentials from a previous invalid login attempt.
  4. ReqWeb has been configured to run on a non-default port. The default port is 80.

Resolving The Problem

The corresponding solutions below match the specific causes referenced above.

  1. Ensure that the RequisitePro project that the report is looking for is shown in the ReqWeb catalog. If not, add the project to the ReqWeb catalog by adding the path to the project RQS file under C:\Program Files\IBM\RationalSDLC\RequisitePro\ReqWeb\Projects\catalog.txt

    Example: If the Out of the Box sample reports do not run, the sample reports may not be listed in the ReqWeb catalog. The projects should be listed by default, but if you have installed to a location other than C:\Program Files\IBM\RationalSDLC, then you will need to modify the path to the sample projects in the ReqWeb catalog before running the reports.

  2. Ensure that the credentials being entered are valid. Try logging in to the RequisitePro project with the same credentials to see if they are valid.

  3. Clear the browser cache to make sure invalid credentials are not cached during report generation. The report should generate successfully.

  4. This error can also be received if the Out of the Box (OOTB) reports are being run on a server that has been configured to use a port besides the standard port 80. The OOTB reports are hard coded with the URL which includes the standard port. To resolve the issue, change the URL within the Report Designer to use the non-standard port. The URL is accessible by double-clicking the ReqPro data source in the BIRT report designer, and modifying the URL to reflect the new server and port. For example, http://localhost/ReqWeb would be changed to http://localhost:8080/ReqWeb.

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Document Information

Modified date:
16 June 2018

UID

swg21375817