Troubleshooting
Problem
In IBM Explorer for z/OS, RSEG1242 error occurs with the description "Daemon failed to launch server on using port ".
Symptom
The message "RSEG1242 'Daemon failed to launch server on <host> using port <port>'", occurs with one of these two details:
- CONNECTION REFUSED
- SERVER FAILURE <message>
Cause
- "CONNECTION REFUSED" means the RSE (Remote System Explorer) daemon is not active.
- "SERVER FAILURE" with a message means the client has contacted the host, but became disconnected.
Environment
z/OS
Resolving The Problem
For CONNECTION REFUSED:
- Check the RSED job output in SDSF (Spool Display and Search Facility).
The RSE daemon is not using the port specified by the client or the RSE daemon is not running. - Check console message FEK002I in the syslog or RSE daemon job output.
A firewall/other network issue is blocking the client from accessing the RSE daemon port.
Port 0 in the RSEG1242 message normally indicates the RSE daemon. - Try telnet from the client machine to the RSE daemon port.
The connection will hang for 30 seconds if successful, but a firewall should display a message.
telnet <host> <port>
If the client can access the RSE daemon, but not RSE server due to firewall issues, this is typically indicated by a non-zero port number in the RSEG1242 message. - Alter the _RSE_PORTRANGE in /rse.env.
Ensure that the ports defined in the port range are open on the firewall.
Port numbers defined in _RSE_PORTRANGE are inclusive.
For the SERVER FAILURE <message>:
The detail shows the error message in rseserver.log only if the RSE daemon/server was reached.
An example is:
- View detailed host logs to see which part of the code failed.
- Set debug_level=3 in /etc/zexpl/rsecomm.properties and restart the RSE daemon
or
use the operator commands to dynamically activate tracing,
/F RSED,APPL=RSL ON and /F RSED,APPL=RCL ON. - After recreating the problem, customize and run FEK.SFEKSAMP(FEKLOGS) to collect FEKLOGS.
Upload with the case for IBM Support.
Related Information
[{"Type":"MASTER","Line of Business":{"code":"LOB35","label":"Mainframe SW"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Product":{"code":"SSTRMM","label":"IBM Developer for z\/OS"},"ARM Category":[{"code":"a8m3p000000F8w6AAC","label":"IBM Explorer for z\/OS-\u003EExplorer for z\/OS Host-\u003EHost Setup_Runtime"}],"ARM Case Number":"","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"All Versions"}]
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Document Information
Modified date:
28 September 2023
UID
swg21460835