IBM Support

RPT may hang when editing or executing tests

Troubleshooting


Problem

Beginning with version 10.1.2, there is a hang condition afflicting IBM Rational Performance Tester (RPT). It manifests most commonly during playback of a test or schedule when the process reaches the 3% progress point. The hang has also been seen when opening test to edit. You are forced to kill RPT's java process to continue but the problem can persist.

Cause

The specific cause is unknown at this time.

Diagnosing The Problem

  1. Start Rational Performance Tester as usual; continue using Rational Performance Tester until a hang occurs.
  2. Once Rational Performance Tester is experiencing a hang, determine the process ID of the JVM.   Depending  on how Rational Performance Tester was started, the JVM will be running as either eclipse.exe or javaw.exe.  Using Task Manager, check for javaw.exe and note its PID.  If there's no javaw.exe, then note the PID of eclipse.exe.  For example, on the example machine, there is no javaw.exe so the PID, 10056, of eclipse.exe was used:
    Windows Task Manager example
  3. On the same machine where Rational Performance Tester is running, start a command prompt and issue the following jconsole.exe command, specifying the PID from Step 2.  For example:
         
    "C:\Program Files\IBM\SDP\jdk\bin\jconsole.exe" 10056
  4. A "Java Monitoring & Management Console" window will appear (this may take several minutes).  You will also see a dialog window with the message "Secure connection failed.  Retry insecurely?".  Click on the "Insecure connection" button.  JConsole should now connect to the running Rational Performance Tester process.
  5. Go to the Threads tab.  If the hang is at 3%, scroll down in the Threads list (on the bottom left) until you find the "main" entry.  Click on main to see the state of the main thread:
    JConsole example
The "Resolving The Problem" section covers providing this data to the product support team but the key indicator within the stack trace is a reference to a specific package:
org.eclipse.hyades.loaders.util.Guid.(Guid.java:292)
If that package appears in the stack trace, you are experiencing this bug and the next action is to seek the available hotfixes.

Resolving The Problem

If uncomfortable with doing the analysis, the stack traces can be sent to the product support team.

  1. After selecting the thread(s) one-at-a-time, select all the text that appears to the right and use Control-C to copy this stack trace to its own file:
    JConsole Stack example
  2. Paste (Control-V) the copied stack trace into a text document and attach it to the support ticket.  As an example, the stack trace for a “main” thread should be similar to:
Name: main
State: RUNNABLE
Total blocked: 0  Total waited: 258
Stack trace:
org.eclipse.swt.internal.win32.OS.WaitMessage(Native Method)
org.eclipse.swt.widgets.Display.sleep(Display.java:4856)
org.eclipse.ui.application.WorkbenchAdvisor.eventLoopIdle(WorkbenchAdvisor.java:368)
…
org.eclipse.equinox.launcher.Main.basicRun(Main.java:590)
org.eclipse.equinox.launcher.Main.run(Main.java:1499)
There are hotfixes available for versions 10.1.2, 10.1.3, and 10.2. Please reach out to the product support team for access.

Document Location

Worldwide

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Document Information

Modified date:
19 November 2021

UID

ibm16486865