Troubleshooting
Problem
User launches main Controller client. User clicks green 'X' button. There is a delay (of approximately 1 minute). Eventually, an error appears.
Symptom
Error Launching menu item "Controller Link"
Error Details:
Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80080005.
Cause
Corrupt installation of Microsoft Excel.
Example:
In one real-life customer example, the client device's Excel 2013 installation had recently been patched with some Microsoft Office updates. Afterwards, the problem occurred.
Diagnosing The Problem
Try to launch Microsoft Excel from the Start menu:
Example:
In one real-life customer example:
- Nothing appeared to happen for some time (many seconds)
- Eventually the following error was seen:
- If a user clicked 'Yes' or 'No' then nothing happened
- In other words, Excel never appeared (even after waiting several minutes).
- Excel couldn't start last time. Safe mode could help you troubleshoot the problem...
Resolving The Problem
Perform a Microsoft Office Repair.
Steps:
Refer to Microsoft documentation for exact steps for your environment.
For example, in one real-life customer example (Excel 2013 hosted on a Windows 2012 Citrix server) the solution was:
1. Ensure that no users were logged onto the Citrix server
2. Launch 'Control Panel' - 'Programs' - 'Programs and Features'
3. Right-click on 'Microsoft Excel 2013' and choose 'Change'
4. Choose 'Repair':
5. Complete the wizard
6. Afterwards, reboot client device
7. Launch Excel, and acknowledge any message
8. Close Excel
9. Test.
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Document Information
Modified date:
15 June 2018
UID
swg22010806