Question & Answer
Question
How can a Microsoft Exchange mailbox be restored when MAPI/CDO is not installed?
Cause
Data Protection for Exchange requires the use of Messaging API/Collaboration Data Objects (MAPI/CDO 1.2.1) to extract mailboxes and their associated messages. In situations where MAPI/CDO cannot be installed it is still possible to use Data Protection to restore the data and extract the mailboxes needed.
Answer
The recovery process is two phases. First the database will need to be restored to a recovery location. Then the mailbox can be extracted using the Exchange command line.
The restore can be done using the Data Protection for Exchange 'Restore Into' function. This allows the database to be restored into a 'Recovery Database' (RDB). The RDB will need to be created prior to starting the restore. Refer to the related documents for specifics on creating the RDB.
Once the RDB is created, the restore into operation can be started. The database and associated transaction logs can be restored at the same time. Only the restored logs should be replayed. Refer to the related documents for specifics on using Data Protection for a restore into operation.
After the restore has completed, and the RDB has been mounted, a mailbox restore can be initiated from the Exchange server. This can accomplished with the New-MailboxRestoreRequest cmdlet. The operation will extract the source mailbox from the RDB and restore it to the target mailbox you select. Refer to the related documents for specifics on using the New-MailboxRestoreRequest cmdlet.
If the newly restored mailbox needs to be extracted to a .PST, this can be performed using the Exchange Server New-MailboxExportRequest command. Refer to the related document for specific on how the cmdlet can be used.
Related Information
Product Synonym
TSM FCM
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Document Information
Modified date:
17 June 2018
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