Troubleshooting
Problem
We have new during migration Exchange 2010 and Exchange 2016 in the organization. When recovering from an e mail, the mailbox is located on Exchange 2010 the task works. If the mailbox is on the Exchange 2016, the restore does not work
Cause
commons-codec-1.3.jar file was missing at the location- <ICC_Install_dir>\AFUWeb\ewa
Note:- This fix given will be part of office 365 release.
Environment
Windows
Resolving The Problem
1. Exit Outlook if it is running.
2. Open the Registry Editor, by clicking on Start and typing
"Regedit.exe".
3. Locate and select the following key in the registry:
4. HKEY_CURRENT_USER > Software > Microsoft > Exchange
5. Check for "MapiHttpDisabled". If "MapiHttpDisabled" does not exist,
right-click in the right window, select New > DWORD, replace "New Value
#1" with "MapiHttpDisabled"
6. Right-click "MapiHttpDisabled" and the click Modify.
7. Change the Value to 1 and then click OK.
8. Close the Registry Editor.
9. Go to C:\Users\<user>\AppData\Local\Microsoft\Outlook
11. Take backup file XXXXXXX - Autodiscover.xml files like (our system is
like 4c46dd8c07268746b23bd7e5e7216566 - Autodiscover.xml) in another
location.
12 Delete this xml files from this location
10. Start Outlook.
11. Restore mail.
Do after the above steps:-
1. Check for the registry entry (like spelling of registry (MapiHttpDisabled) added)
2. stop ICC WebApp
3. Take the backup of logs of ICC (<ICC_Install_dir>/ctms/log directory) and deleted all logs inside it.
4. copy the file commons-codec-1.3.jar from <ICC_Install_dir>\ctms to <ICC_Install_dir>\AFUWeb\ewas\lib\ext
5.Restart the web app service and checked the restoration and check restoration is working or not.
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Document Information
Modified date:
14 September 2018
UID
ibm10731609