IBM Support

Resolving 'OutOfMemoryException' Errors When Importing Data into Analyst's Notebook

Troubleshooting


Problem

When importing spreadsheet data using an import specification in Analyst's Notebook, the import fails with a 'System.OutOfMemoryException' error message. In some cases, the message may read 'Error: Too many fields defined'

Symptom

Cause

This error message is commonly caused by having too many blank cells (white space) in the spreadsheet.

Resolving The Problem

To resolve this error message, manually reset the used range in the spreadsheet by deleting unused rows & columns:

Select the last cell that contains data in the worksheet.


To delete any unused rows:
Move down one row from the last cell with data.
Hold the Ctrl and Shift keys, and press the Down Arrow key
Right-click in the selected cells, and, from the shortcut menu, choose Delete
Select Entire Row, click OK.



To delete any unused columns:
Move right one column from the last cell with data.
Hold the Ctrl and Shift keys, and press the Right Arrow key
Right-click in the selected cells, and, from the shortcut menu, choose Delete
Select Entire Column, click OK.

Save the file.

Note: In older versions of Excel, you may have to Save, then close and re-open the file before the used range is reset.
[{"Product":{"code":"SSXUXD","label":"i2 Analyst's Notebook"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.9;8.7;8.5;8.0","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Document Information

More support for:
i2 Analyst's Notebook

Software version:
8.9, 8.7, 8.5, 8.0

Operating system(s):
Windows

Document number:
483477

Modified date:
16 June 2018

UID

swg21616757