Troubleshooting
Problem
When you deploy IBM Content Navigator on a WebSphere Application Server, the deployment fails. The deployment failure usually occurs with WebSphere Application Server 7, but can also occur with other WebSphere Application Server versions.
Symptom
The deployment fails and an error message is displayed. For example:
WASX7017E: Exception received while running file "/opt/IBM/ECMClient/configure/tmp/deployapplication.tcl"; exception information: com.ibm.websphere.management.application.client.AppDeploymentException: com.ibm.websphere.management.application.client.AppDeploymentException: [Root exception is java.lang.OutOfMemoryError]
java.lang.OutOfMemoryError: java.lang.OutOfMemoryError
Cause
The default minimum and maximum heap sizes in the wsadmin file are too small.
Environment
WebSphere Application Server and WebSphere Application Server Network Deployment
Diagnosing The Problem
The IBM Content Navigator EAR file deployment fails on WebSphere Application Server with an "Out of Memory" error message.
Resolving The Problem
To resolve the problem, you must edit the wsadmin.sh or wsadmin.bat file:
- Set the Java virtual machine (JVM) initial heap size to 512 MB.
- Set the Java virtual machine (JVM) maximum heap size to 1024 MB.
Related resources
For more information, refer to the following topics in the WebSphere Application Server information center:
- To locate the wsadmin file, see the following topic:
- Starting the wsadmin scripting client using wsadmin scripting (WebSphere Application Server)
- Starting the wsadmin scripting client using wsadmin scripting (WebSphere Application Server Network Deployment)
- To edit the wsadmin file, see the following topic:
- Using the wsadmin scripting tool (WebSphere Application Server)
- Using the wsadmin scripting tool (WebSphere Application Server Network Deployment)
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Document Information
Modified date:
17 June 2018
UID
swg21647230