IBM Support

Resolving missing data collector issues after Storage Insights migration

Troubleshooting


Problem

I have data collectors that appear as 'Missing' in IBM Storage Insights following migration to the new Storage Insights architecture. How do I fix this?

Symptom

IBM Storage Insights instance migration results in data collector(s) showing with 'Missing' status in the user interface.

Cause

There are several cases that can lead to this problem:
1) a data collector that was not upgraded to the latest level prior to the migration
2) a data collector that is still running and associated with the old instance that has not yet been decommissioned
3) the data collector server needs to be granted permission (firewall/security) to the new insights.ibm.com url
4) the data collector is running on a server platform that is no longer supported by IBM Storage Insights

Environment

IBM Storage Insights data collector running on any of the supported platforms.

Diagnosing The Problem

This problem is evident when you see 'Missing' reported as the status for one or more data collectors in the IBM Storage Insights user interface.

Resolving The Problem

1) a data collector that was not upgraded to the latest level prior to the migration
For case #1:
a. stop, uninstall and cleanup the existing data collector on your server
b. download and install a new data collector from your new IBM Storage Insights ui
2) a data collector that is still running and associated with the old instance that has not yet been decommissioned
For case #2:
a. follow steps (a) and (b) for case #1 above
b. if your old legacy IBM Storage Insights instance is still accessible (at https://gui-<subscriptionid>.ib.ibmserviceengage.com/srm/gui) and an entry remains for this data collector, click to highlight it and then right-click and 'Remove' it.
3) the data collector server needs to be granted permission (firewall/security) to the new insights.ibm.com url
For case #3:
a. on the data collector server, try to open a web browser to https://insights.ibm.com:443. If this does not work, then:
b. you will need to work with your security team to make sure the firewall rules allow communication to the new server url and port.
4) the data collector is running on a server platform that is no longer supported by IBM Storage Insights
For case #4:
a. upgrade the server to a supported operating system platform (refer to the 'Planning' section in the IBM Storage Insights documentation), or:
b. install the data collector on a different server that is running a supported operating system
If these solutions do not resolve the issue, please open a new support case with IBM Support for assistance in further diagnosing and resolving the problem.

Document Location

Worldwide

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Document Information

Modified date:
08 February 2022

UID

ibm16470333