IBM Support

Resolving Known Issues in ACS WinApp Pkg to v11.29

Troubleshooting


Problem

After installing the IBM i Access Client Solutions WinApp Pkg v11.29 (Windows Application Package), you might encounter problems with 32-bit OLEDB connections, Active X applications, applications detecting the proper version of our software, the CWBCOTRC output not being found, and the inability to change the FIPS compliance on and off in the properties.

Symptom

You receive an error such as the following when you use a 32-bit application making use of one of our OLEDB providers or Active X components:  "xxxxx provider is not registered on the local machine".

Cause

Version 29 was a big update that included:

  • Upgrading to gskit 9 (so the client is no longer dependent on an outdated visual c runtime).
  • Moving the application to "Program Files" rather than "Program Files (x86).
  • An updated installer.  

There were a few issues with the new installer that were not caught before the update was released.

Diagnosing The Problem

 

Resolving The Problem

From a Windows command line using elevated authority (Run As Administrator), run the following commands:

 

These correct issues with the version information being incomplete:

reg.exe add "HKLM\SOFTWARE\IBM\Client Access\CurrentVersion" /f /reg:32 /t REG_SZ /v "Release" /d "1"

reg.exe add "HKLM\SOFTWARE\IBM\Client Access\CurrentVersion" /f /reg:32 /t REG_SZ /v "ModificationLevel" /d "0"

reg.exe add "HKLM\SOFTWARE\IBM\Client Access\CurrentVersion" /f /reg:32 /t REG_SZ /v "CurrentFixLevel" /d "29"

 

These correct issues with the cwbcotrc output file location:

reg.exe add "HKLM\SOFTWARE\IBM\Client Access\CurrentVersion" /f /reg:32 /t REG_SZ /v "ServiceFolder" /d "Service"

reg.exe add "HKLM\SOFTWARE\IBM\Client Access\CurrentVersion" /f /reg:32 /t REG_SZ /v "TraceFolder" /d “Trace Files”

 

This registers the 32-bit support for our OLE-DB provider and Active-X components:

regsvr32 c:\windows\syswow64\cwbzzodb.dll

regsvr32 "C:\Program Files\IBM\Client Access\Shared\cwbx.dll"

 

To work around the problems setting FIPS compliance, launch the properties control panel widget as an Administrator.  If you do not have the shortcut in a desktop folder, the location of the widget is C:\Windows\System32\ca400cpl.cpl open file explorer, navigate to that file, right-click it and select ' Run as administrator'.

Document Location

Worldwide

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Product Synonym

i5/OS;OS/400;System i operating system;iSeries Operating System;AS/400 operating system;PowerHA for IBM i;PowerHA SystemMirror for IBM i;Db2 Mirror for i;Cloud Storage Solutions for i;Access Client Solutions;Developer Kit for Java for IBM i;HTTP Server for IBM i;Network Authentication Enablement for IBM i;OmniFind Text Search Server for DB2 for IBM i;Portable Utilities for IBM i;TCP/IP Connectivity Utilities for IBM i;Transform Services for IBM i;Cryptographic Device Manager;Query for i;Db2 Query Manager and SWL Development Kit;IBM i Access Family;Rational Development Studio;AS400;IBM i Db2;IBM i Extension for VS Code Enterprise Support;WebSphere Application Server for IBM i

Document Information

Modified date:
27 April 2026

UID

ibm17270137