IBM Support

Resolving Error 129 When Running Server Commands on Client

Troubleshooting


Problem

User is attempting to run Server commands for WebSphere® Data Interchange for zOS on Client and they are encountering error 129.

Cause



Error 129 means it did not find the symbolic link in the DB2 WLM stored procedure address space.

Environment

zOS WDI 3.3

Resolving The Problem

The symbolic (external) link needs to be done under the home directory for the user id for which the WLM is started. For example, if it is started under WDIUSER id and the home folder for its OMVS segment is: /u/wdiuser

Then, issue the following command from OMVS under present working directory "/u/wdiuser" to define the external link:

ln -e EDISERVR /u/wdiuser/EDISERVR

For more information, see bullet (5) under section 2.1.11.2 of the WDI 3.3 for z/OS Installation Guide and review the following Webcast replay: Configuring WebSphere Data Interchange 3.3 for z/OS Stored Procedures in a WLM Application Environment.

[{"Product":{"code":"SSFKTZ","label":"WebSphere Data Interchange"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"WDI 3.3 z\/OS","Platform":[{"code":"PF035","label":"z\/OS"}],"Version":"3.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

More support for:
WebSphere Data Interchange

Software version:
3.3

Operating system(s):
z/OS

Document number:
93567

Modified date:
16 June 2018

UID

swg21289983