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Resolving ANS2124W messages concerning lock on node replication table

Troubleshooting


Problem

ANS2124W messages related to node replication table seen in dsmerror.log

Cause

This message indicates the Backup-Archive client is unable to access the tsmnrtable.DB file associated with the client node. The tsmnrtable.DB is used when a client is configured for failover replication, it stores information about the backup operation, such as date of last backup, server name, etc and serves as a local database for comparison with information on the Spectrum Protect server.

Diagnosing The Problem

dsmerror.log will show multiple occurrences of the following messages:
05/03/2016 22:24:14 ANS0361I DIAG: dbOpen(): error opening/creating
lock file 'C:\Program Files\Tivoli\TSM\baclient\tsmnrtable.DB.Lock' .
05/03/2016 22:24:14 ANS2124W Client node replication table is locked by another process.

Resolving The Problem

This problem is more commonly seen when there are multiple client nodes configured on the same host for backup operations.

When multiple client nodes utilizing failover replication are configured to the same client system the NRTABLEPATH option needs to be specified in the dsm.opt or dsm.sys file otherwise both nodes will use the default location resulting in these warning messages.

More information about the default location of the tsmnrtable.DB file and NRTABLEPATH option below:


https://www.ibm.com/support/knowledgecenter/SSGSG7_7.1.6/client/r_opt_nrtablepath.html

In these cases, the problem can be resolved by specifying a different NRTABLEPATH for one of the client nodes. Each client node should have it's own replication node table (tsmnrtable.DB)

These messages can also be seen if the Backup-Archive client cannot access the tsmnrtable.DB file due to permissions or if the file is somehow in use by another process such as an antivirus application. In which case the administrator needs to confirm the user has sufficient permissions to the tsmnrtable.DB file or that it is not in use by another process.

[{"Product":{"code":"SSEQVQ","label":"IBM Spectrum Protect"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1.3;7.1.4;7.1.5","Edition":"","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21983747