Troubleshooting
Problem
This technote provides workarounds for resolving conflicts between IBM® Rational® RequisitePro® and Adobe Acrobat which cause the RequisitePro menu to disappear and the communication error -5, "Unable to communicate with Microsoft® Word..." error.
Cause
RequisitePro and Adobe Acrobat use the same location in the Word menu bar. When Word is launched from RequisitePro, Adobe Acrobat takes over the menu bar location which RequisitePro uses.
Resolving The Problem
Adobe Acrobat 6.0:
Take one of the following actions to resolve this menu conflict between and RequisitePro:
- Prevent the PDFMaker.dot file from loading automatically by removing it from the following location:
C:\Program Files\Microsoft Office\Office\Startup
And also check this startup directory:
C:\Documents and Settings\<user>\Application Data\Microsoft\Word\STARTUP
- In Microsoft Word, access Tools > Template and Add-Ins.
Clear the checkbox for the file PDFMaker.dot.
Do this for each RequisitePro document you are working with.
Note: For version 2003.06.13-16 and 7.x the ReqPro10.dot document template is used. - Replace the ReqPro##.dot file with a copy of the file from a machine that does not experiencing this issue.
- Uninstall Adobe Acrobat 6.0
Adobe Acrobat 7.0 and later:
This version of Acrobat uses a COM Add-in instead of a .dot template to load the Adobe menu in Microsoft Word. Disable the Adobe Acrobat Word Menu by unregistering pdfmofficeaddin.dll using regsvr32.
Note: The default install path for the pdfmofficeaddin.dll is:
C:\program files\adobe\acrobat 7.0\pdfmaker\office\
- Disabling the Adobe Acrobat 7.0 integration with Microsoft Word:
- Close all Microsoft Word instances.
- Select Start > Run..., enter CMD and click OK
- Enter the following command at the command prompt:
regsvr32 /u "c:\program files\adobe\acrobat 7.0\pdfmaker\office\pdfmofficeaddin.dll"
- This will disable the Adobe Acrobat 7.0 integration with Microsoft Word and will allow you to use RequisitePro with out conflict
- Close all Microsoft Word instances.
- Select Start > Run..., enter CMD and click OK
- Enter the following command at the command prompt:
regsvr32 "c:\program files\adobe\acrobat 7.0\pdfmaker\office\pdfmofficeaddin.dll"
- This will enable the Adobe Acrobat 7.0 integration with Microsoft Word
Automated Batch file for this operation:
Run the pdfmakeroff.bat to disable the Adobe Acrobat 7.0 integration with Word and then open RequisitePro.
Enabling the Adobe Acrobat 7.0 integration with Microsoft Word:
Automated Batch file for this operation:
Run the PDFMakerON.bat to enable the Adobe Acrobat 7.0 integration with Word.
Changing the Adobe Acrobat 7.0 load behavior:
Forcing the Adobe Acrobat 7.0 com add-in to load on demand instead of automatically will enable you to workaround this issue.
Note: In making the following changes you are effectively disabling the integration of Acrobat and Microsoft Word. To enable the integration of Acrobat and Word, you have to revert the following changes.
NOTE: This solution contains information about modifying the system registry. Before making any modifications to the Microsoft® Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to the Microsoft Knowledge Base article 256986 http://support.microsoft.com/kb/256986.
- Access Start > Run... and enter regedit
- Navigate to the following registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin
Note: Create the registry key if it does not exist. - Update the key named LoadBehavior from the value of 3 to 0
- Navigate to the following registry key:
HKEY_CURRENT_USER\SOFTWARE\Microsoft\Office\Word\Addins\PDFMaker.OfficeAddin
- Update the key named LoadBehavior from the value 3 to 8
Note: Create the registry key if it does not exist.
Note: This sets Adobe to load on demand when accessed from Tools > COM add-ins dialog
Modifying the COM-Addins...:
Some programs which interface with Microsoft Word use a COM-Addin instead of a document template (.dot) to load their menus and functions. These steps have you expose the COM-Addins command button in Microsoft Word to validate what Add-ins are running when using RequisitePro.
- In an open RequisitePro document, select Tools > Customize
- In the Customize dialog box, select the Commands tab.
- In the Categories box, click Tools.
- Drag COM Add-Ins from the Commands box to a Tool bar or menu in the Word interface such as the Tools menu.

- In the Customize dialog box click Close.
- Click the COM Add-Ins button to view the active Add-ins.
- To Unload an Add-in: clear the check box next to the add-in name.
- To Load an Add-in: place a check into the check box next to the add-in name
- To Add an Add-in: Click Add... and navigate to the *.DLL that is used with the program
Note: RequisitePro uses the ReqPro10.dll in versions 2003.06.13-16 and in 7.x - Unload the COM Add-in for Adobe which is interfering with RequisitePro
Was this topic helpful?
Document Information
Modified date:
16 June 2018
UID
swg21175325