IBM Support

Repeating Keys Do Not Work by default on Mac OS

Troubleshooting


Problem

The IBM i Access Client Solutions (ACS) product now provides a very robust IBM i OS interaction environment for users on the Apple Mac OS, including a 5250 display emulator. By default in the Mac OS holding a key does not cause it to repeat and this is a commonly used function within a 5250 interactive job.

Symptom

Holding a key does not cause it to repeat entry by default on the Apple Mac OS causing a loss of behavior for some users of the IBM i Access Client Solutions 5250 emulator.

Cause

This is a normal default of the Apple Mac OS to not repeat keys when held.

Environment

Apple Mac OS

Diagnosing The Problem

This behavior is not caused from within any IBM software like IBM i Access Client Solutions but instead is rooted within default behavior of the Apple Mac OS.

Resolving The Problem

The letter keys and number keys do not repeat when held down on the Apple MAC OS by default. This behavior can be changed from within the Mac OS. On Apple Mac OSX this can be done by entering the following commands from a terminal session.

To enable repeating keys when held, Enter:

defaults write -g ApplePressAndHoldEnabled -bool false

To disable repeating keys when held (return to default), Enter:

defaults write -g ApplePressAndHoldEnabled -bool true

Note: The above commands were tested to work on Apple Mac OSX, though support for this change within the Mac OS would be the responsibility of whomever provides Mac OS support.


[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"Platform":[{"code":"PF012","label":"IBM i"}],"Version":"7.1.0"}]

Document Information

More support for:
IBM i

Software version:
7.1.0

Operating system(s):
IBM i

Document number:
645995

Modified date:
22 April 2025

UID

nas8N1020524

Manage My Notification Subscriptions