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Repeated errors in the Windows event log Solid Database Error 10006

Troubleshooting


Problem

In IBM Content Collector (ICC) cluster, there are many repeated error message in the Windows event log: Event ID 117 SOLID Database Error 10006: Concurrency conflict, two transactions updated or deleted the same row.

Symptom

The following error stack trace is reported in the Windows event log:

Event ID 117


    'Failed to execute statement.' error details : { state : '40001' native
    error : 10006 message : 'SOLID Database Error 10006: Concurrency
    conflict, two transactions updated or deleted the same row' }
    ibm::ctms::taskrouting::`anonymous namespace'::
    HandleblocklistInfo
    (taskrouteengine.cpp:88)
    0xb20
    Stack Trace:
    (class ibm::ctms::datastore::odbc::OdbcException)
      at ibm::ctms::datastore::soliddb::NoRowSetCommand::execute
    (soliddbcommand.cpp:180),
      at ibm::ctms::datastore::soliddb::`anonymous
    namespace'::DeleteAccessor::DeleteAccessor
    (soliddbblocklisttable.cpp:439),
      at
    ibm::ctms::datastore::soliddb::
    SolidDBblocklistTable::deleteMatching
    (soliddbblocklisttable.cpp:1307),
      at ibm::ctms::taskrouting::`anonymous
    namespace'::HandleblocklistInfo (taskrouteengine.cpp:66),
      at ibm::ctms::taskrouting::`anonymous
    namespace'::<lambda2>::operator() (taskrouteengine.cpp:456)
    ,

Cause

Errors with writing blocklist entry into SOLID database in an ICC cluster environment.

Environment

IBM Content Collector 4.0.1 with cluster.

Diagnosing The Problem

The error stopped when the secondary node is shut down temporarily.

Resolving The Problem

As a workaround, perform the following steps to clear the blocklist once:

  • In ICC Configuration Manager, go to the Tools menu and select blocklist.
  • Select the checkbox Include total row count and click Apply.
  • Take note of the total number of records in the blocklist. The more items in the blocklist, the longer it will take to clear the list.
  • Click Clear blocklist.

Note that after clearing the blocklist, previous failed emails may get re-processed by ICC and they may fail and get added back to the blocklist again. This is fine because the email connector error that resulted in the blocklist record did not actually lead to the Solid DB error.
[{"Product":{"code":"SSAE9L","label":"Content Collector"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Content Collector for Email","Platform":[{"code":"PF033","label":"Windows"}],"Version":"4.0.1;4.0.1.2;4.0.1.3","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

More support for:
Content Collector

Software version:
4.0.1, 4.0.1.2, 4.0.1.3

Operating system(s):
Windows

Document number:
284669

Modified date:
17 June 2018

UID

swg21986963

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