IBM Support

Recovery from a B6000901 Link Loader error

Troubleshooting


Problem

Recovery from a B6000901 Link Loader error

Cause

Link Loader Bad flag turned on during PTF apply

Environment

PTFs

Diagnosing The Problem

The system has halted during PTF apply with a B6000901. An IPL to the "B" side fails with SRCB6000901, but IPL to the "A" side is successful.

Resolving The Problem

To recover from an SRCB6000901 a SLIP install of License Internal code must be performed from a known good copy of SAVSYS media or from a License Internal Code DVD that matches the currently installed version and release level. It can be a newer resave level.

This recovery can be performed from either a physical DVD, tape or image catalog. Using the I_BASE_01 image in a VIOS Virtual Media Library also falls under the physical DVD scope, as it reports into the IBM i as an OPTxx device. If the slip fails using an image catalog, then use either physical DVD or tape to perform this recovery.

Note: To use an image catalog for slipping LIC after a link loader failure, ensure the PTF for MA49387 is perm applied to the system. For 7.4 the fix required is MF69535 and for 7.5 the fix required is MF69562. The fix is part of the base code for 7.6 and later.

If there is a working DVD drive on another partition on the same server, then you could virtualize the optical as documented in Using NWSD (Network Server Description) to Virtualize Optical Drive to Share Optical Between i Partitions

[{"Type":"MASTER","Line of Business":{"code":"LOB68","label":"Power HW"},"Business Unit":{"code":"BU070","label":"IBM Infrastructure"},"Product":{"code":"SWG60","label":"IBM i"},"ARM Category":[{"code":"a8m0z0000000C4BAAU","label":"IBM i"}],"ARM Case Number":"","Platform":[{"code":"PF012","label":"IBM i"}],"Version":"All Versions"}]

Document Information

Modified date:
22 July 2025

UID

nas8N1020581