IBM Support

Receiving error when running Who is on Hold Report

Troubleshooting


Problem

When you run Who is hold report in Atlas without using filters, it fails with the following error. "Cannot get a column count" SQL Error #1 Connection has already been closed"

Symptom

Not able to run Who is On Hold Report without using any Filters but other BIRT reports works fine

Cause

The issue happens when you run who is on hold report without filters and happens on Atlas deployed in Weblogic application server.

Environment

Atlas deployed on Weblogic application server.

Diagnosing The Problem

In addition to the error message in the user interface, you will see the following exception in Atlas log(PAearlog.log)

<Forcibly releasing inactive connection
"weblogic.jdbc.wrapper.PoolConnection_oracle_jdbc_driver_T4CConnection@3
0" back into the connection pool "AtlasReportsDS", currently reserved
by: java.lang.Exception
at
weblogic.jdbc.common.internal.ConnectionEnv.setup(ConnectionEnv.java:318
)

This happens because the Weblogic releases connections forcibly assuming it to be inactive

Resolving The Problem

  1. Login to Weblogic Administration Console.
  2. Navigate to the JDBC Datasource --> AtlasReportsDS > Connection Pool > Advanced Section.
  3. Change the Inactive Connection Timeout to 0
  4. A restart of the application server may be required.

[{"Product":{"code":"SS5JP8","label":"Atlas eDiscovery Process Management"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Reports","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"6.0;6.0.1;6.0.1.1;6.0.1.2;6.0.1.3;6.0.1.4","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 June 2018

UID

swg21660209