IBM Support

Receiving "API Initialization Failed" error when loading the Viewer

Troubleshooting


Problem

You receive an "API Initialization Failed" error when loading the Viewer for Lotus Forms. This technote discusses possible causes and solutions.

Cause

The Viewer can fail to load for a few reasons:

1. A custom IFX file, located at C:\Program Files\IBM\Lotus Forms\Viewer\3.0\extensions, might be corrupt or not built correctly.

2. There are insufficient privileges on a custom IFX file located in the C:\Program Files\IBM\Lotus Forms\Viewer\3.0\extensions folder.

Resolving The Problem

To resolve the problem, take the following steps:

Check permissions


    Check the permissions of the custom IFX files within the C:\Program Files\IBM\Lotus Forms\Viewer\3.0\extensions folder.

    The DefaultSigningCeremony.ifx, SpellChecker.ifx, or viewer.ifx are not custom IFXs. Do not make any changes to the permissions on these files.

    Make sure you have full read, write, and read & execute permissions on the custom IFX files installed.


Verify validity of IFX files

    If the permission's on the IFX are correct, then perform the following steps:

    1. Remove the custom IFX files from C:\Program Files\IBM\Lotus Forms\Viewer\3.0\extensions folder


      NOTE: Do not remove DefaultSigningCeremony.ifx, SpellChecker.ifx, or viewer.ifx

    2. Restart the Viewer to verify the Viewer is now loading correctly.

      If only one custom IFX is being used and the Viewer loads correctly after removing the IFX, then you know the custom IFX is either corrupt or not built correctly.

    If you have more than one custom IFX, you can verify which IFX is creating the problem by:

    1. Stopping the Viewer

    2. Put one custom IFX file back into the C:\Program Files\IBM\Lotus Forms\Viewer\3.0\extensions folder

    3. Restart the Viewer

    When you get the initialization error again, you will know which custom IFX is corrupt or not built correctly.


If you require assistance in determining how your IFX might be broken, beyond what we have described in this technote, please contact IBM Support.

Related Information

[{"Product":{"code":"SS38QR","label":"Lotus Forms Viewer"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"--","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.5;3.0.1;3.0","Edition":"","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

More support for:
Lotus Forms Viewer

Software version:
3.5, 3.0.1, 3.0

Operating system(s):
Windows

Document number:
93199

Modified date:
15 November 2019

UID

swg21289165

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