IBM Support

Receive Error after logging in to Forms Experience Builder

Troubleshooting


Problem

FEB is not accessible after installation and see ClassCastException in SystemOut.log

Symptom

Browser shows the following error after logging into FEB:
An error has occurred in processing your request. The error message is displayed below.
We are unable to process your request. If this error persists, report the problem to your administrator and provide error reference: 97f559e9-158f-4ecd-b3d3-02a7638f66d1

And the SystemOut.log shows:
[4/9/14 3:30:42:431 CDT] 0000005a StandardExcep E com.ibm.form.nitro.
platform.StandardExceptionMapper toResponse 97f559e9-158f-4ecd-b3d3-
02a7638f66d1
java.lang.ClassCastException: com.ibm.
form.platform.service.rest.jaxrs.SurrogateCapability incompatible with
java.lang.Comparable
at java.util.TreeMap.toComparable(TreeMap.java:5518)
at java.util.TreeMap.putImpl(TreeMap.java:4545)
at java.util.TreeMap.put(TreeMap.java:4541)
at java.util.TreeSet.add(TreeSet.java:122)
at com.ibm.form.platform.service.rest.jaxrs.
RESTRequestHeadersMultivaluedMap._loadValueObjectList
(RESTRequestHeadersMultivaluedMap.java:368)
at com.ibm.form.platform.service.rest.jaxrs.
RESTRequestHeadersMultivaluedMap.getAs(RESTRequestHeadersMultivaluedMap.
java:150)

Cause

This is caused by a JDK defect explained in http://www-01.ibm.com/support/docview.wss?uid=swg1IV52621

Resolving The Problem

You can upgrade to SR15 or downgrade to SR5.

[{"Product":{"code":"SS6KJL","label":"IBM Forms Experience Builder"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Installation","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"8.6;8.5.1;8.5","Edition":"","Line of Business":{"code":"LOB31","label":"WCE Watson Marketing and Commerce"}}]

Document Information

Modified date:
16 June 2018

UID

swg21670605