IBM Support

RCL API Log XML files are being created on ClearCase hosts

Troubleshooting


Problem

New files with the name RCL_API_Log_Sample_1_0__1.xml are created on IBM Rational ClearCase clients for each connection to the License host.

Symptom

Contents of the file:
<?xml version="1.0" encoding="UTF-8"?>
<?xml-stylesheet type="text/xsl" href="RCL_Log.xsl"?>
<RCL_Log>
<Product>Sample</Product>
<Version>1.0</Version>
<TimeStamp>2014-07-31T13:13:40-00:00</TimeStamp>
<Record>
<Thread_Id>-161854880</Thread_Id>
<Event>General</Event>
<Text>RCL Client Version</Text>
<Desc>Release :- 8.1.3.3; Build :- RCL8133-I20130324_1305</Desc>
</Record>
<Record>
<Thread_Id>-161854880</Thread_Id>
<Event>General</Event>
<Text>The RCL Log Configuration file wasn't found.</Text>
<Desc>/opt/rational/clearcase/config/rcl</Desc>
</Record>
</RCL_Log>

Cause

The RCL Log Configuration file is missing or the RCL Logging is enabled

Environment

This problem has been identified in Solaris and Linux environments but may affect other ones as well.

Diagnosing The Problem

Open one of the XML log files and look for the specific messages under sections <Event></Event>, <Text></Text> and <Desc></Desc>

Resolving The Problem

Select one of the following:

  • If the XML log file contains the message "The RCL Log Configuration file wasn't found" then create a file named "RCL_Log_Config.txt" in the specified directory ( the default location is/opt/rational/clearcase/config/rcl ) with the following contents:
  • Location =


    Product =
    Version =
    Size =
    LogLevel =
    TraceLevel =
    MaxFiles =
    EnableLogging = 0
    EnableTracing = 0

  • If the XML log files seems to contain tracing or logging messages with no specific error, then the Logging and/or Tracing are enabled on the configuration file.
    If Logging or Tracing are not really required, disable them by editing the "RCL_Log_Config.txt" and setting the value 0 (zero) to EnableLogging and EnableTracing.

  • If you find other errors in the log XML files contact IBM Rational technical support for further assistance.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Rational Common Licensing","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF010","label":"HP-UX"}],"Version":"8.0;8.0.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21665155