IBM Support

RC=127 failure for client scheduler

Troubleshooting


Problem

When running a command schedule that launches a script, this is failing immediately with an RC=127

Cause

If a command is not found, the child process created to execute it returns a status of 127.

Diagnosing The Problem

Trace the schedule to get the output for the exact command that is being launched.

Check the Tivoli Storage Manager Server activity log for the messages that show the schedule being launched.

Check the IP address for the start of the session to verify that the correct machine is being contacted.

Resolving The Problem

The return code RC=127, for Korn Shell scripting means "Command not Found" and is typically caused by:

  • a typographical error within the script.
  • a path variable not available because an environment is not sourced.
  • a filesystem is not mounted for a location referenced by the command.
  • the underlying file/command is not found because it was accidentally deleted or renamed.
  • the schedule is being run on a different system than expected (where the script file does not exist).

Check the system to ensure the script files exists in the location that is specified.

Verify that the environment variables (if any) are being sourced within the script. Since the scheduler deamon is started by the inittab, variable definitions are not initialized/available within the scheduler environment.
Update the node that is running the schedule to have a HLADDRESS and LLADDRESS that will direct the schedule to be started on the desired machine.

[{"Product":{"code":"SSGSG7","label":"Tivoli Storage Manager"},"Business Unit":{"code":"BU058","label":"IBM Infrastructure w\/TPS"},"Component":"Client","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All Supported Versions","Edition":"Edition Independent","Line of Business":{"code":"LOB26","label":"Storage"}}]

Product Synonym

TSM

Document Information

Modified date:
17 June 2018

UID

swg21657480