IBM Support

Raising threshold of Media error counts on host

Troubleshooting


Problem

Media error count are set to 5, which is too low.

Symptom


HostDisk 1256 rack1.host2.hostDisk5 Active Warning

Cause

Media errors on disk are counted for multiple different issues. If count is not raising dramatically, these counts can be ignored. Raising threshold of system will get rid of warnings.

Diagnosing The Problem

Command below will show you the media error count on all disk on the host. Review this list. Monitor disk for a few days. If disk count raises, replace disk. If it does not, raise threshold.
/opt/nz-hwsupport/hts/mega_check.pl -c

Resolving The Problem

This will cause a 30 minute outage to complete. here are the steps below:

1. nzsystem showRegistry | grep -i media <---- Check current setting
2. vi /nz/data.1.0/config/system.cfg <--- change to media errors and other to 100
ADD:
sysmgr.hostDiskMediaErrThresholdToRiseEvent = 100
sysmgr.hostDiskOtherErrThresholdToRiseEvent = 100

3. nzsystem pause
4. nzsystem set -regFile /nz/data.1.0/config/system.cfg <----- Load config file
5. nzsystem resume
6. nzsystem showRegistry | grep -i media <--- Check new setting

[{"Product":{"code":"SSULQD","label":"IBM PureData System"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"1.0.0","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
17 October 2019

UID

swg21684267